File python-gobject.spec of Package python3-gobject

#
# spec file for package python-gobject
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define build_for_python3 0

%if %{build_for_python3}
%define local_py_requires Requires: python(abi) = %py3_ver
%define local_py_sitedir  %{python3_sitearch}
%define local_py_suffix   3
%define local_py_pkg      python3
%define local_lib_ver     3-0
%else
%define local_py_requires %{py_requires}
%define local_py_sitedir  %{py_sitedir}
%define local_py_suffix   2
%define local_py_pkg      python 
%define local_lib_ver     2-0
%endif

Name:           python-gobject
%define _name   pygobject
Summary:        Python bindings for GObject
License:        LGPL-2.1+
Group:          Development/Libraries/Python
Version:        3.10.2
Release:        0
Url:            http://ftp.gnome.org/pub/GNOME/sources/pygobject/
Source:         http://download.gnome.org/sources/pygobject/3.10/%{_name}-%{version}.tar.xz
Patch1:         pycompile-searchpath.patch
BuildRequires:  fdupes
BuildRequires:  glib2-devel >= 2.35.9
BuildRequires:  gobject-introspection-devel >= 1.35.9
BuildRequires:  libffi-devel
%if %{build_for_python3}
BuildRequires:  python3-cairo-devel
BuildRequires:  python3-devel
%else
BuildRequires:  python-cairo-devel
BuildRequires:  python-devel
%endif
BuildRequires:  pkgconfig(cairo)
BuildRequires:  pkgconfig(cairo-gobject)
# Trigger an automatic installation of python(3)?-gobject when python and libgirepository are installed.
Supplements:    packageand(%{local_py_pkg}:libgirepository-1_0-1)
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%{local_py_requires}

%description
Pygobjects is an extension module for python that gives you access to
GLib's GObjects.

%package cairo
Summary:        Python bindings for GObject -- Cairo bindings
Group:          Development/Libraries/Python
Requires:       %{name} = %{version}
%define cairo_real_package %(rpm -q --qf '%%{NAME}' --whatprovides cairo)
Supplements:    packageand(%{name}:%{cairo_real_package})

%description cairo
Pygobjects is an extension module for python that gives you access to
GLib's GObjects.

This package contains the Python Cairo bindings for GObject.

%package -n libpyglib-gi-2_0-python%{local_lib_ver}
Summary:        Python Gobject Introspeciton binding
Group:          System/Libraries

%description -n libpyglib-gi-2_0-python%{local_lib_ver}
Pygobjects is an extension module for python that gives you access to
GLib's GObjects.

The bindings are handled by gobject-introspection libraries.

%package devel
Summary:        Python bindings for GObject
Group:          Development/Libraries/Python
Requires:       %{name} = %{version}
Requires:       libpyglib-gi-2_0-python%{local_lib_ver} = %{version}
%if ! %{build_for_python3}
# If somebody wants the -devel package, we provide the full set.
Requires:       python3-gobject-devel
%endif

%description devel
This package contains files required to build wrappers for gobject
addon libraries such as pygtk.

%prep
%setup -q -n %{_name}-%{version}
%patch1 -p1

%build
%if %{build_for_python3}
export PYTHON=python3
%endif
%configure
make %{?jobs:-j%jobs} V=1

%install
%makeinstall
find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' | xargs rm -f
%if %{build_for_python3}
# If we're building for python3, we remove the header and .pc file...
# Those files are python-version agnostic... so it does not matter.
rm -r %{buildroot}%{_includedir}/pygobject-3.0/pygobject.h
rm %{buildroot}%{_libdir}/pkgconfig/pygobject-3.0.pc
%endif
# Drop pygtkcompat layer.it's useless and we lack other stuff for it to work
rm %{buildroot}%{local_py_sitedir}/gi/pygtkcompat.py
rm -r %{buildroot}%{local_py_sitedir}/pygtkcompat/
rm examples/Makefile*
%fdupes $RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%post -n libpyglib-gi-2_0-python%{local_lib_ver} -p /sbin/ldconfig

%postun -n libpyglib-gi-2_0-python%{local_lib_ver} -p /sbin/ldconfig

%files
%defattr(-,root,root)
%doc AUTHORS NEWS README ChangeLog examples
%{local_py_sitedir}/gi/
%{local_py_sitedir}/*.egg-info
# Lives in cairo subpackage
%exclude %{local_py_sitedir}/gi/_gi_cairo*.so

%files -n libpyglib-gi-2_0-python%{local_lib_ver}
%defattr(-, root, root)
%{_libdir}/libpyglib-gi-2.0-python%{local_py_suffix}.so.0*

%files cairo
%defattr(-,root,root)
%{local_py_sitedir}/gi/_gi_cairo*.so

%files devel
%defattr(-,root,root)
%{_libdir}/*.so
%if ! %{build_for_python3}
%{_includedir}/pygobject-3.0/
%{_libdir}/pkgconfig/pygobject-3.0.pc
%endif

%changelog
openSUSE Build Service is sponsored by