File python-eventlet.spec of Package python-eventlet
#
# spec file for package python-eventlet
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name: python-eventlet
Version: 0.20.0
Release: 0
Summary: Concurrent networking library for Python
License: MIT
Group: Development/Languages/Python
Url: http://eventlet.net
Source: https://files.pythonhosted.org/packages/source/e/eventlet/eventlet-%{version}.tar.gz
Patch0: 0001-Fix-SSL-connection-reset-errors.patch
# PATCH-FIX-UPSTREAM PR-459.patch -- https://github.com/eventlet/eventlet/pull/459
Patch1: PR-459.patch
BuildRequires: %{python_module Sphinx}
BuildRequires: %{python_module devel}
BuildRequires: %{python_module greenlet}
BuildRequires: %{python_module setuptools}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
%if %python_version_nodots < 34
Requires: python-enum34
%endif
# eventlet parses /etc/protocols which is not available in normal build envs
Requires: netcfg
Requires: python-greenlet >= 0.3
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildArch: noarch
%python_subpackages
%description
Eventlet is a concurrent networking library for Python that allows
changing how code is run.
It uses epoll or libevent for scalable non-blocking I/O. Coroutines
ensure that the developer uses a blocking style of programming that is similar
to threading, but provide the benefits of non-blocking I/O. The event dispatch
is implicit, which means Eventlet can be used from the Python
interpreter, or as part of a larger application.
%package doc
Summary: Documentation for the Eventlet concurrent networking library
Group: Development/Libraries/Python
Requires: %{name} = %{version}
%description doc
Documentation for Eventlet, which is a concurrent networking library
for Python that allows changing how code is run.
%prep
%setup -q -n eventlet-%{version}
%patch0 -p1
%patch1 -p1
sed -i '/enum.compat/d' setup.py # crude way to drop the strange "enum-compat" requirement
sed -i "s|^#!.*||" eventlet/support/greendns.py # Fix non-executable script
%build
%python_build
%python_exec setup.py build_sphinx && rm build/sphinx/html/.buildinfo
%install
%python_install
%fdupes %{buildroot}%{_prefix}
%files %{python_files}
%defattr(-,root,root,-)
%doc AUTHORS LICENSE NEWS README.rst
%{python_sitelib}/*
%files %{python_files doc}
%defattr(-,root,root,-)
%doc build/sphinx/html examples
%changelog