File md_monitor.spec of Package md_monitor.32005
#
# spec file for package md_monitor
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: md_monitor
BuildRequires: libaio-devel
BuildRequires: libudev-devel
Requires: mdadm
URL: http://github.com/hreinecke/md_monitor
Summary: MD device monitor
License: GPL-2.0-or-later
Group: Development/Tools/Other
Version: 6.6+11+gcbb8940
Release: 0
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Source0: %{name}-%{version}.tar.xz
PreReq: %fillup_prereq
%systemd_requires
%description
The md_monitor daemon monitors the component devices of each MD array
for I/O issues. It will update the monitored MD arrays on each status
change, setting devices to 'faulty' or re-integrate working devices.
Authors:
--------
Hannes Reinecke <hare@suse.de>
%prep
%setup -q -n %{name}-%{version}
%build
make OPTFLAGS="$RPM_OPT_FLAGS"
%install
make DESTDIR=$RPM_BUILD_ROOT install
%if ! %{defined _fillupdir}
%define _fillupdir /var/adm/fillup-templates
%endif
if [ "%{_fillupdir}" != /var/adm/fillup-templates \
-a -d $RPM_BUILD_ROOT/var/adm/fillup-templates ]; then
install -d -m 755 $RPM_BUILD_ROOT%{_fillupdir}
mv -f -t $RPM_BUILD_ROOT%{_fillupdir} \
$RPM_BUILD_ROOT/var/adm/fillup-templates/sysconfig.md_monitor
rm -rf $RPM_BUILD_ROOT/var/adm
fi
%clean
rm -rf $RPM_BUILD_ROOT
%pre
%service_add_pre md_monitor.service
%post
%fillup_only
%service_add_post md_monitor.service
%preun
%service_del_preun md_monitor.service
%postun
%service_del_postun md_monitor.service
%files
%defattr(-,root,root)
/sbin/md_monitor
/sbin/setdasd
%{_mandir}/man8/md_monitor.8*
%{_mandir}/man8/setdasd.8*
/usr/share/misc/md_notify_device.sh
%{_unitdir}/md_monitor.service
%{_fillupdir}/sysconfig.md_monitor
%doc README.md
%changelog