File fwupdate.changes of Package fwupdate.12922

-------------------------------------------------------------------
Wed Oct 16 06:58:36 UTC 2019 - Gary Ching-Pang Lin <glin@suse.com>

- Add fwupdate-bsc1152928-update-aarch64-linker-script.patch to
  update the linker script for AArch64 to match the one in
  gnu-efi (bsc#1152928)

-------------------------------------------------------------------
Mon Jan 28 08:14:59 UTC 2019 - Gary Ching-Pang Lin <glin@suse.com>

- Fix the destination of 'efi'-executables for i586 (FATE#326960)

-------------------------------------------------------------------
Thu Jan 17 16:10:37 UTC 2019 - rw@suse.com

- Move 'efi'-executables to '/usr/share/efi'  (FATE#326960)

-------------------------------------------------------------------
Tue Oct 23 03:42:04 UTC 2018 - Gary Ching-Pang Lin <glin@suse.com>

- Amend the spec file to avoid fwup*.efi from being removed
  mistakenly (bsc#1112832)

-------------------------------------------------------------------
Thu Jul 19 21:56:34 UTC 2018 - bjorn.lie@gmail.com

- Update to version 12 (FATE#326702)
  + Better CI.
  + Limit how large our WMI buffer can be.
  + Add fwup_version() because fwupd wants it.
  + Fix linking on (some) platforms that need libgcc_eh.a.
  + abicheck improvements.
  + Default to creating a UX capsule, whatever it may actually do.
- Refresh fwupdate-suse-build.patch with quilt.
- Use url for source tarball and license tag for COPYING.

-------------------------------------------------------------------
Thu Jun 28 06:25:59 UTC 2018 - glin@suse.com

- Correct the requirement of efivar-devel version

-------------------------------------------------------------------
Wed Jun 20 11:59:51 UTC 2018 - oliver@getspam.de

- Update to version 11
  + lots of fixes from cov-scan and clang analyzer
  + support for Lenovo machines
  + experimental support for UI Capsules
  + Dell WMI support
  + lots of bugfixes
  + configurable EFI ESP location by setting ESPMOUNTPOINT or the git
    config property fwupdate.espmountdir during the build.
  + Lots of coverity work
  + ABI compatibility checking during the release process
  + Make subdirectory builds work
- removed fwupdate-list-firmware-types.patch

-------------------------------------------------------------------
Mon Apr  9 03:37:59 UTC 2018 - glin@suse.com

- Require shim only for x86_64 (bsc#1088434)

-------------------------------------------------------------------
Fri Feb  9 09:58:45 UTC 2018 - glin@suse.com

- Remove fwupdate-bsc988886-add-leading-space.patch and bump the
  shim version requirement since we got the new signature for shim
  (bsc#1054712)

-------------------------------------------------------------------
Mon Dec 18 10:42:01 CET 2017 - mls@suse.de

- bring back accidental removed needssslcertforbuild

-------------------------------------------------------------------
Fri Dec 15 15:37:49 UTC 2017 - stefan.bruens@rwth-aachen.de

- EFI updates through fwupdate are also possible on Aarch64.
  smbios support is only relevant for some Dell machines, i.e.
  x86 only.

-------------------------------------------------------------------
Thu Dec 14 14:37:10 CET 2017 - mls@suse.de

- disable _unique_debug_names fow now
  fwupdate wants to install it's own debug files, but doesn't know
  about this option yet

-------------------------------------------------------------------
Mon Nov 20 03:10:06 UTC 2017 - glin@suse.com

- Add back fwupdate-bsc988886-add-leading-space.patch due to the
  long pending shim signature request. Also drop the shim version
  requirement.

-------------------------------------------------------------------
Tue Aug 29 10:24:16 UTC 2017 - glin@suse.com

- Update to 9+git21.gcd8f7d7 (FATE#322805)
- Add the new BuildRequires: libsmbios-devel
- Update the so version of libfwup
- Refresh fwupdate-suse-build.patch
- Remove the upstream patches
  + fwupdate-fix-efivar-0.24-api.patch
  + fwupdate-bsc988000-set-a-mode-with-efi_set_variable.patch
  + fwupdate-unset-immutable-flag.patch
- Drop fwupdate-bsc988886-add-leading-space.patch (Need shim >= 11)
- Add fwupdate-list-firmware-types.patch to list the supported
  firmware types

-------------------------------------------------------------------
Thu Mar 30 04:10:51 UTC 2017 - glin@suse.com

- Remove the debug source and info of the EFI files when disabling
  the debug build (bsc#1031554)
  + Also remove the efi-debuginfo subpackage since the debug file
    is packaged correctly now.

-------------------------------------------------------------------
Thu Mar  9 15:43:29 UTC 2017 - rw@suse.com

- Enable efivar API patch based on pkg-config data and require
  at least gnu-efi-3.0.2.  (ramification of FATE#322108)

-------------------------------------------------------------------
Thu Jul 28 06:38:09 UTC 2016 - glin@suse.com

- Relax the requirement of efivar-devel and disable the efivar API
  patch for openSUSE Leap 42.x and SLE

-------------------------------------------------------------------
Thu Jul 21 02:11:31 UTC 2016 - glin@suse.com

- Amend the spec file to detect SLE/openSUSE (bsc#990228)

-------------------------------------------------------------------
Fri Jul 15 03:45:05 UTC 2016 - glin@suse.com

- Add fwupdate-fix-efivar-0.24-api.patch to fix the compilation
  errors due to the change of efivar APIs
- Bump BuildRequires of efivar-devel to 0.24
- Add fwupdate-unset-immutable-flag.patch to unset the immutable
  flag before clean the EFI variables (bsc#964726)
- Amend fwupdate-suse-build.patch (FATE#319345)
  + omit the build-id and package fwudpate-efi-debuginfo in a less
    hacky way.
  + Use the RPM_OPT_FLAGS for the user space programs
- Add fwupdate-bsc988886-add-leading-space.patch to add the leading
  space to the load option (bsc#988886)

-------------------------------------------------------------------
Thu Jul  7 03:11:01 UTC 2016 - glin@suse.com

- Correct the EFI dir for SLE-12-SP2 (FATE#319345)
- Install fwup*.efi to the EFI system partition (FATE#319345)
- Add fwupdate-bsc988000-set-a-mode-with-efi_set_variable.patch to
  fix the file mode (bsc#988000)

-------------------------------------------------------------------
Sun May  8 19:10:52 UTC 2016 - jengelh@inai.de

- Drop unnecessary specfile elements.
  fwupdate seems not required for libfwup, remove the requirement.
- Correct requires of fwupdate-devel
- Use source URLs

-------------------------------------------------------------------
Fri May  6 15:58:30 UTC 2016 - coolo@suse.com

- own bash-completion directory as no longer provided by
  util-linux (boo#977259)

-------------------------------------------------------------------
Mon Mar 28 09:16:51 UTC 2016 - glin@suse.com

- Add the missing Group

-------------------------------------------------------------------
Wed Mar  2 08:24:12 UTC 2016 - glin@suse.com

- initial import 0.5 (FATE#319345)
- Add fwupdate-suse-build.patch to change the destination of the
  EFI files and remove the po files
openSUSE Build Service is sponsored by