File libksba-CVE-2022-3515.patch of Package libksba.26429

From 4b7d9cd4a018898d7714ce06f3faf2626c14582b Mon Sep 17 00:00:00 2001
From: Werner Koch <wk@gnupg.org>
Date: Wed, 5 Oct 2022 14:19:06 +0200
Subject: [PATCH 1/3] Detect a possible overflow directly in the TLV parser.

* src/ber-help.c (_ksba_ber_read_tl): Check for overflow of a commonly
used sum.
--

It is quite common to have checks like

    if (ti.nhdr + ti.length >= DIM(tmpbuf))
       return gpg_error (GPG_ERR_TOO_LARGE);

This patch detects possible integer overflows immmediately when
creating the TI object.

Reported-by: ZDI-CAN-18927, ZDI-CAN-18928, ZDI-CAN-18929

Index: libksba-1.3.5/src/ber-help.c
===================================================================
--- libksba-1.3.5.orig/src/ber-help.c
+++ libksba-1.3.5/src/ber-help.c
@@ -181,6 +181,12 @@ _ksba_ber_read_tl (ksba_reader_t reader,
       ti->length = len;
     }
 
+  if (ti->length > ti->nhdr && (ti->nhdr + ti->length) < ti->length)
+    {
+      ti->err_string = "header+length would overflow";
+      return gpg_error (GPG_ERR_EOVERFLOW);
+    }
+
   /* Without this kludge some example certs can't be parsed */
   if (ti->class == CLASS_UNIVERSAL && !ti->tag)
     ti->length = 0;
openSUSE Build Service is sponsored by