File python-ddt.spec of Package python-ddt

#
# spec file for package python-ddt
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%bcond_without test
Name:           python-ddt
Version:        1.1.1
Release:        0
Summary:        Data-Driven/Decorated Tests
License:        MIT
Group:          Development/Languages/Python
Url:            https://github.com/txels/ddt
Source:         https://files.pythonhosted.org/packages/source/d/ddt/ddt-%{version}.tar.gz
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
BuildRequires:  python-rpm-macros
# SECTION test requirements
BuildRequires:  %{python_module PyYAML}
BuildRequires:  %{python_module mock}
BuildRequires:  %{python_module nose}
# /SECTION

%python_subpackages

%description
A library to multiply test cases.

%prep
%setup -q -n ddt-%{version}

%build
%{python_build}

%install
%{python_install}

%check
%{python_exec setup.py test}

%files %{python_files}
%defattr(-,root,root,-)
%{python_sitelib}/*
%doc *.md

%changelog
openSUSE Build Service is sponsored by