File terraform-provider-google.spec of Package terraform-provider-google.16152

#
# spec file for package terraform
#
# Copyright (c) 2020 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#

# Make sure that the binary is not getting stripped.
%if 0%{?suse_version}
%{go_nostrip}
%endif

Name:           terraform-provider-google
Version:        2.20.3
Release:        0
License:        MPL-2.0
Summary:        Terraform provider for Google Cloud Platform (GCP)
Url:            https://github.com/terraform-providers/terraform-provider-google
Group:          System/Management
Source:         %{name}-%{version}.tar.gz
Source1:        vendor.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
%if 0%{?ubuntu_version}
BuildRequires:  debhelper
BuildRequires:  dh-golang
BuildRequires:  xz-utils
BuildRequires:  golang-go
BuildRequires:  pkg-config
BuildRequires:  libvirt-dev
%else
%if 0%{?fedora} || 0%{?rhel_version} || 0%{?centos_version}
BuildRequires:  golang
%endif
%if 0%{?suse_version}
BuildRequires:  golang-packaging
BuildRequires:  golang(API) >= 1.12
%endif
Requires:       terraform >= 0.11.0
%endif
%if 0%{?suse_version}
%{go_provides}
%endif

%description
This is a terraform provider that lets you provision servers on Google Cloud
Platform via Terraform.

%prep
%setup -q -n %{name}-%{version}
%setup -q -D -T -a 1 -n %{name}-%{version}

%build
%goprep github.com/terraform-providers/terraform-provider-google
%gobuild --mod=vendor ""

%install
%goinstall
rm -rf %{buildroot}/%{_libdir}/go/contrib

%files
%defattr(-,root,root,-)
%doc CHANGELOG.md README.md LICENSE
%{_bindir}/%{name}

%changelog

openSUSE Build Service is sponsored by