File libjpeg-turbo.spec of Package libjpeg62-turbo.15341

#
# spec file for package libjpeg-turbo
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#

%define asan_build 0
%define debug_build 0

%define srcver   1.5.3
%define major    8
%define minor    1
%define micro    2
%define libver   %{major}.%{minor}.%{micro}
%define tmajor   0
%define tminor   1
%define tmicro   0
%define tlibver  %{tmajor}.%{tminor}.%{tmicro}

Name:           libjpeg-turbo
Version:        %{srcver}
Release:        0
Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
License:        BSD-3-Clause
Group:          Productivity/Graphics/Convertors
Url:            http://sourceforge.net/projects/libjpeg-turbo
Source0:        http://downloads.sf.net/libjpeg-turbo/libjpeg-turbo-%{version}.tar.gz
Source1:        baselibs.conf
Patch1:         libjpeg-turbo-1.3.0-tiff-ojpeg.patch
Patch2:         libjpeg-1.4.0-ocloexec.patch
Patch3:         libjpeg-turbo-CVE-2018-11813.patch
Patch4:         libjpeg-turbo-CVE-2018-1152.patch
# CVE-2018-14498 [bsc#1128712]
Patch5:         libjpeg-turbo-CVE-2018-14498.patch
# CVE-2019-2201 [bsc#1156402]
Patch6:         libjpeg-turbo-CVE-2019-2201.patch
# CVE-2020-13790 [bsc#1172491], heap-based buffer over-read in get_rgb_row() in rdppm.c via a malformed PPM input file
Patch7:         libjpeg-turbo-CVE-2020-13790.patch
BuildRequires:  gcc-c++
BuildRequires:  libtool
BuildRequires:  pkgconfig
BuildRequires:  yasm
Obsoletes:      jpeg = 6b
Obsoletes:      jpeg = 8.0.1
Obsoletes:      jpeg = 8.0.2
Provides:       jpeg = %{version}
Obsoletes:      jpeg < %{version}
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Conflicts:      jpeg%{major}

%description
The libjpeg-turbo package contains a library of functions for manipulating
JPEG images. It also includes the following command line utilities:
  djpeg - decompress a JPEG file to an image file
  jpegtran - lossless transformation of JPEG files
  rdjpgcom - display text comments from a JPEG file
  wrjpgcom - insert text comments into a JPEG file
  tjbench - a JPEG decompression/compression benchmark 

%package -n libjpeg%{major}
Version:        %{libver}
Release:        0
Summary:        The MMX/SSE accelerated JPEG compression/decompression library
# bug437293
Group:          System/Libraries
%ifarch ppc64
Obsoletes:      libjpeg-64bit < %{version}
%endif
#

%description -n libjpeg%{major}
This library contains MMX/SSE accelerated functions for manipulating
JPEG images.

%package -n libturbojpeg%{tmajor}
Version:        %{version}
Release:        0
Summary:        The MMX/SSE accelerated JPEG compression/decompression library
Group:          System/Libraries

%description -n libturbojpeg%{tmajor}
This library contains MMX/SSE accelerated functions for manipulating
JPEG images.

%package -n libjpeg%{major}-devel
Version:        %{libver}
Release:        0
Summary:        Development Tools for applications which will use the Libjpeg Library
Group:          Development/Libraries/C and C++
Requires:       libjpeg%{major} = %{version}
Requires:       libturbojpeg%{tmajor} = %{version}
Provides:       libjpeg-devel = %{version}
Obsoletes:      libjpeg-devel < %{version}
Conflicts:      otherproviders(libjpeg-devel)
# bug437293
%ifarch ppc64
Obsoletes:      libjpeg-devel-64bit < %{version}
%endif
#

%description -n libjpeg%{major}-devel
The libjpeg-devel package includes the header files and libraries
necessary for compiling and linking programs which will manipulate JPEG
files using the libjpeg library.

%prep
%setup -q 
%patch1
%patch2
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1

%build
export LDFLAGS="-Wl,-z,relro,-z,now"
%if %{debug_build}
CFLAGS="%{optflags} -O0"
%endif
%configure --disable-static \
           --disable-silent-rules \
           --with-build-date=$(date --utc --date="@${SOURCE_DATE_EPOCH:-$(date +%s)}" +%Y%m%d) \
           --with-jpeg8
%if %{asan_build}
find -name Makefile | xargs sed -i 's/\(^CFLAGS.*\)/\1 -fsanitize=address/'
%endif
make %{?_smp_mflags}

%check
%if %{asan_build}
# ASAN needs /proc to be mounted
exit 0
%endif
make test libdir=%{_libdir}

%install
%make_install
# Remove unwanted files
rm -f %{buildroot}%{_libdir}/lib{,turbo}jpeg.la
# Remove docs, we'll select docs manually
rm -rf %{buildroot}%{_datadir}/doc/

%post -n libjpeg%{major} -p /sbin/ldconfig

%postun -n libjpeg%{major} -p /sbin/ldconfig

%post -n libturbojpeg%{tmajor} -p /sbin/ldconfig

%postun -n libturbojpeg%{tmajor} -p /sbin/ldconfig

%files
%defattr(-,root,root)
%doc README.md change.log ChangeLog.md
%doc usage.txt wizard.txt
%{_bindir}/*
%doc %{_mandir}/man1/*

%files -n libjpeg%{major}
%defattr(-,root,root)
%{_libdir}/libjpeg.so.%{libver}
%{_libdir}/libjpeg.so.%{major}

%files -n libturbojpeg%{tmajor}
%defattr(-,root,root)
%{_libdir}/libturbojpeg.so.%{tmajor}
%{_libdir}/libturbojpeg.so.%{tlibver}

%files -n libjpeg%{major}-devel
%defattr(-,root,root)
%{_includedir}/*.h
%{_libdir}/libjpeg.so
%{_libdir}/libturbojpeg.so
%{_libdir}/pkgconfig/libjpeg.pc
%{_libdir}/pkgconfig/libturbojpeg.pc
%doc coderules.txt jconfig.txt libjpeg.txt structure.txt example.c

%changelog
openSUSE Build Service is sponsored by