File python-argcomplete.spec of Package python-argcomplete.32346

#
# spec file for package python-argcomplete
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2013 Darin Perusich.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{!?license: %global license %doc}
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-argcomplete
Version:        1.9.2
Release:        0
Summary:        Bash tab completion for argparse
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            https://github.com/kislyuk/argcomplete
Source:         https://files.pythonhosted.org/packages/source/a/argcomplete/argcomplete-%{version}.tar.gz
Patch0:         skip_tcsh_tests.patch
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
BuildRequires:  python-rpm-macros
# SECTION tests
BuildRequires:  %{python_module coverage}
BuildRequires:  %{python_module flake8}
BuildRequires:  %{python_module pexpect}
BuildRequires:  %{python_module wheel}
# END SECTIONS tests
Requires:       python-wheel
Requires(post): update-alternatives
Requires(postun):update-alternatives
BuildArch:      noarch
%python_subpackages

%description
Argcomplete provides easy, extensible command line tab completion of
arguments for your Python script.

It makes two assumptions:

* You're using bash as your shell
* You're using argparse to manage your command line arguments/options

Argcomplete is particularly useful if your program has lots of options
or subparsers, and if your program can dynamically suggest completions
for your argument/option values (for example, if the user is browsing
resources over the network).

%prep
%setup -q -n argcomplete-%{version}
%patch0 -p1

%build
%python_build

%install
%python_install
rm -rf %{buildroot}%{python_sitelib}/test
rm %{buildroot}%{_bindir}/activate-global-python-argcomplete
%python_clone -a %{buildroot}%{_bindir}/python-argcomplete-check-easy-install-script
%python_clone -a %{buildroot}%{_bindir}/register-python-argcomplete
install -DTm644 %{buildroot}%{python_sitelib}/argcomplete/bash_completion.d/python-argcomplete.sh %{buildroot}%{_sysconfdir}/bash_completion.d/python-argcomplete.sh
%python_clone -a %{buildroot}%{_sysconfdir}/bash_completion.d/python-argcomplete.sh
# tcsh support is broken
rm %{buildroot}%{_bindir}/python-argcomplete-tcsh

%check
export LANG=en_US.UTF-8
%python_exec setup.py test

%post
%{python_install_alternative register-python-argcomplete python-argcomplete-check-easy-install-script %{_sysconfdir}/bash_completion.d/python-argcomplete.sh}

%postun
%{python_uninstall_alternative register-python-argcomplete python-argcomplete-check-easy-install-script %{_sysconfdir}/bash_completion.d/python-argcomplete.sh}

%files %{python_files}
%defattr(-,root,root)
%doc README.rst
%license LICENSE.rst
%{python_sitelib}/argcomplete
%{python_sitelib}/argcomplete-%{version}-py%{python_version}.egg-info
%python_alternative %{_bindir}/python-argcomplete-check-easy-install-script
%python_alternative %{_bindir}/register-python-argcomplete
%python_alternative %{_sysconfdir}/bash_completion.d/python-argcomplete.sh

%changelog
openSUSE Build Service is sponsored by