File python-cffi.spec of Package python-cffi.9418

#
# spec file for package python-cffi
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%define         modname cffi
Name:           python-%{modname}
Version:        1.11.2
Release:        0
Summary:        Foreign Function Interface for Python calling C code
License:        MIT
Group:          Development/Languages/Python
Url:            http://%{modname}.readthedocs.org
Source0:        https://files.pythonhosted.org/packages/source/c/cffi/%{modname}-%{version}.tar.gz
Source1:        python-cffi-rpmlintrc
Patch0:         cffi-loader.patch
Patch1:         dont-corrupt-memory.patch
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module pycparser}
BuildRequires:  %{python_module pytest}
BuildRequires:  %{python_module setuptools}
BuildRequires:  gcc-c++
BuildRequires:  pkgconfig
BuildRequires:  python-rpm-macros
BuildRequires:  fdupes
BuildRequires:  pkgconfig(libffi)
Requires:       python-pycparser
%python_subpackages

%description
Foreign Function Interface for Python calling C code. The aim of this project
is to provide a convenient and reliable way of calling C code from Python.

%prep
%setup -q -n %{modname}-%{version}
%autopatch -p1

%build
export CFLAGS="%{optflags}"
%python_build

%install
%python_install

%check
%{python_expand export PYTHONPATH=%{buildroot}%{$python_sitearch}
# py.test-%%$python_bin_suffix -k "not test_init_once_multithread" c/ testing/
py.test-%$python_bin_suffix c/ testing/
}

%files %{python_files}
%license LICENSE
%{python_sitearch}/*

%changelog
openSUSE Build Service is sponsored by