File python-google-api-python-client.spec of Package python-google-api-python-client.14697

#
# spec file for package python-google-api-python-client
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


# Test scripts not included in source archive
# https://github.com/google/google-api-python-client/issues/513
%bcond_with test

%if 0%{?sle_version} < 150000
%define skip_python3 1
%{?!python_module:%define python_module() python-%{**}}
%else
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%endif
Name:           python-google-api-python-client
Version:        1.7.4
Release:        0
Summary:        Google APIs Python Client
License:        Apache-2.0
Group:          Development/Languages/Python
Url:            https://github.com/google/google-api-python-client
Source:         https://files.pythonhosted.org/packages/source/g/google-api-python-client/google-api-python-client-%{version}.tar.gz
Patch0:         hidePythonDeps.patch
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module google-auth >= 1.4.1}
BuildRequires:  %{python_module google-auth-httplib2 >= 0.0.3}
BuildRequires:  %{python_module httplib2 >= 0.9.2}
BuildRequires:  %{python_module oauth2client >= 1.5.0}
BuildRequires:  %{python_module setuptools}
BuildRequires:  %{python_module six >= 1.6.1}
BuildRequires:  %{python_module uritemplate  >= 3.0.0}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
%if %{with test}
# Test requirements
BuildRequires:  %{python_module nose}
# Python 2 test requirements
BuildRequires:  python-mock
%endif
Requires:       python-google-auth >= 1.4.1
Requires:       python-google-auth-httplib2 >= 0.0.3
Requires:       python-httplib2 >= 0.9.2
Requires:       python-six >= 1.6.1
Requires:       python-uritemplate  >= 3.0.0
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
# Package renamed in SLE 12, do not remove Provides, Obsolete directives
# until after SLE 12 EOL
Provides:       google-api-python-client = %{version}
Obsoletes:      google-api-python-client < %{version}
%python_subpackages

%description
Google APIs Client Library for Python

%prep
%setup -q -n google-api-python-client-%{version}
%patch0

%build
%python_build

%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%if %{with test}
%check
%python_expand nosetests-%{$python_bin_suffix}
%endif

%files %{python_files}
%defattr(-,root,root,-)
%doc CHANGELOG
%license LICENSE
%{python_sitelib}/*

%changelog
openSUSE Build Service is sponsored by