File python-websocket-client.spec of Package python-websocket-client.14495

#
# spec file for package python-websocket-client
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


# RHEL provides this backport in its own repository
%if 0%{?rhel} == 7
%define ssl_match_hostname python-backports-ssl_match_hostname
%else
%define ssl_match_hostname python-backports.ssl_match_hostname
%endif

%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%bcond_without test
Name:           python-websocket-client
Version:        0.44.0
Release:        0
Summary:        WebSocket client implementation
License:        LGPL-3.0
Group:          Development/Languages/Python
Url:            https://github.com/liris/websocket-client/releases
Source0:        https://files.pythonhosted.org/packages/source/w/websocket-client/websocket_client-%{version}.tar.gz
# PATCH-FIX-OPENSUSE use_system_cabundle.patch bnc#1076519
Patch0:         use_system_cabundle.patch
BuildRequires:  %ssl_match_hostname
BuildRequires:  %{python_module devel}
BuildRequires:  %{python_module setuptools}
BuildRequires:  %{python_module six}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
Requires:       python-six
Requires(post): update-alternatives
Requires(postun): update-alternatives
%ifpython2
Requires:       %ssl_match_hostname
%endif
Provides:       python-websocket-client-test = %{version}
Obsoletes:      python-websocket-client-test < %{version}
BuildArch:      noarch

%python_subpackages

%description
The websocket-client module is a WebSocket client for Python. This provides the
low-level APIs for WebSocket. All APIs are synchronous functions.

Websocket-client supports only hybi-13.

%prep
%setup -q -n websocket_client-%{version}
%patch0 -p1

%build
%python_build

%install
%python_install
%python_clone -a %{buildroot}%{_bindir}/wsdump.py

%python_expand %fdupes %{buildroot}/%{$python_sitelib}

%if %{with test}
%check
%python_exec websocket/tests/test_websocket.py
%endif

%post
%python_install_alternative wsdump.py

%postun
%python_uninstall_alternative wsdump.py

%files %{python_files}
%defattr(-,root,root,-)
%doc LICENSE README.rst
%python_alternative %{_bindir}/wsdump.py
%{python_sitelib}/websocket/
%{python_sitelib}/websocket_client-%{version}-py*.egg-info

%changelog
openSUSE Build Service is sponsored by