File python-azure-mgmt-synapse.spec of Package python-azure-mgmt-synapse.32838
#
# spec file for package python-azure-mgmt-synapse
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%if 0%{?suse_version} >= 1500
%define skip_python2 1
%endif
Name: python-azure-mgmt-synapse
Version: 2.1.0b2
Release: 0
Summary: Microsoft Azure Synapse Management Client Library
License: MIT
Group: Development/Languages/Python
URL: https://github.com/Azure/azure-sdk-for-python
Source: https://files.pythonhosted.org/packages/source/a/azure-mgmt-synapse/azure-mgmt-synapse-%{version}.zip
Source1: LICENSE.txt
BuildRequires: %{python_module azure-mgmt-nspkg >= 3.0.0}
BuildRequires: %{python_module azure-nspkg >= 3.0.0}
BuildRequires: %{python_module setuptools}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
BuildRequires: unzip
Requires: python-azure-common < 2.0.0
Requires: python-azure-common >= 1.1
Requires: python-azure-mgmt-core < 2.0.0
Requires: python-azure-mgmt-core >= 1.2.0
Requires: python-azure-mgmt-nspkg >= 3.0.0
Requires: python-azure-nspkg >= 3.0.0
Requires: python-msrest >= 0.6.21
Conflicts: python-azure-sdk <= 2.0.0
BuildArch: noarch
%python_subpackages
%description
This is the Microsoft Azure Synapse Management Client Library.
This package has been tested with Python 2.7, 3.5, 3.6, 3.7 and 3.8.
%prep
%setup -q -n azure-mgmt-synapse-%{version}
%build
install -m 644 %{SOURCE1} %{_builddir}/azure-mgmt-synapse-%{version}
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%{python_expand # delete common files
rm -rf %{buildroot}%{$python_sitelib}/azure/mgmt/__init__.*
rm -rf %{buildroot}%{$python_sitelib}/azure/mgmt/__pycache__
rm -rf %{buildroot}%{$python_sitelib}/azure/__init__.*
rm -rf %{buildroot}%{$python_sitelib}/azure/__pycache__
}
%files %{python_files}
%defattr(-,root,root,-)
%doc CHANGELOG.md README.md
%license LICENSE.txt
%{python_sitelib}/azure/mgmt/synapse
%{python_sitelib}/azure_mgmt_synapse-*.egg-info
%changelog