File ghc-yesod-form.spec of Package ghc-yesod-form
#
# spec file for package ghc-yesod-form
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%global pkg_name yesod-form
%global pkgver %{pkg_name}-%{version}
%bcond_with tests
Name: ghc-%{pkg_name}
Version: 1.7.9
Release: 0
Summary: Form handling support for Yesod Web Framework
License: MIT
URL: https://hackage.haskell.org/package/%{pkg_name}
Source0: https://hackage.haskell.org/package/%{pkg_name}-%{version}/%{pkg_name}-%{version}.tar.gz
BuildRequires: ghc-Cabal-devel
BuildRequires: ghc-aeson-devel
BuildRequires: ghc-aeson-prof
BuildRequires: ghc-attoparsec-devel
BuildRequires: ghc-attoparsec-prof
BuildRequires: ghc-base-devel
BuildRequires: ghc-base-prof
BuildRequires: ghc-blaze-builder-devel
BuildRequires: ghc-blaze-builder-prof
BuildRequires: ghc-blaze-html-devel
BuildRequires: ghc-blaze-html-prof
BuildRequires: ghc-blaze-markup-devel
BuildRequires: ghc-blaze-markup-prof
BuildRequires: ghc-byteable-devel
BuildRequires: ghc-byteable-prof
BuildRequires: ghc-bytestring-devel
BuildRequires: ghc-bytestring-prof
BuildRequires: ghc-containers-devel
BuildRequires: ghc-containers-prof
BuildRequires: ghc-data-default-devel
BuildRequires: ghc-data-default-prof
BuildRequires: ghc-email-validate-devel
BuildRequires: ghc-email-validate-prof
BuildRequires: ghc-network-uri-devel
BuildRequires: ghc-network-uri-prof
BuildRequires: ghc-persistent-devel
BuildRequires: ghc-persistent-prof
BuildRequires: ghc-resourcet-devel
BuildRequires: ghc-resourcet-prof
BuildRequires: ghc-rpm-macros
BuildRequires: ghc-shakespeare-devel
BuildRequires: ghc-shakespeare-prof
BuildRequires: ghc-text-devel
BuildRequires: ghc-text-prof
BuildRequires: ghc-time-devel
BuildRequires: ghc-time-prof
BuildRequires: ghc-transformers-devel
BuildRequires: ghc-transformers-prof
BuildRequires: ghc-wai-devel
BuildRequires: ghc-wai-prof
BuildRequires: ghc-xss-sanitize-devel
BuildRequires: ghc-xss-sanitize-prof
BuildRequires: ghc-yesod-core-devel
BuildRequires: ghc-yesod-core-prof
BuildRequires: ghc-yesod-persistent-devel
BuildRequires: ghc-yesod-persistent-prof
ExcludeArch: %{ix86}
%if %{with tests}
BuildRequires: ghc-hspec-devel
BuildRequires: ghc-hspec-prof
%endif
%description
API docs and the README are available at
<http://www.stackage.org/package/yesod-form>. Third-party packages which you
can find useful: <http://hackage.haskell.org/package/yesod-form-richtext
yesod-form-richtext> - richtext form fields (currently it provides only
Summernote support).
%package devel
Summary: Haskell %{pkg_name} library development files
Requires: %{name} = %{version}-%{release}
Requires: ghc-compiler = %{ghc_version}
Requires(post): ghc-compiler = %{ghc_version}
Requires(postun): ghc-compiler = %{ghc_version}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%package -n ghc-%{pkg_name}-doc
Summary: Haskell %{pkg_name} library documentation
Requires: ghc-filesystem
BuildArch: noarch
%description -n ghc-%{pkg_name}-doc
This package provides the Haskell %{pkg_name} library documentation.
%package -n ghc-%{pkg_name}-prof
Summary: Haskell %{pkg_name} profiling library
Requires: ghc-%{pkg_name}-devel = %{version}-%{release}
Supplements: (ghc-%{pkg_name}-devel and ghc-prof)
%description -n ghc-%{pkg_name}-prof
This package provides the Haskell %{pkg_name} profiling library.
%prep
%autosetup -n %{pkg_name}-%{version}
%build
%ghc_lib_build
%install
%ghc_lib_install
%check
%cabal_test
%post devel
%ghc_pkg_recache
%postun devel
%ghc_pkg_recache
%files -f %{name}.files
%license LICENSE
%files devel -f %{name}-devel.files
%doc ChangeLog.md README.md
%files -n ghc-%{pkg_name}-doc -f ghc-%{pkg_name}-doc.files
%license LICENSE
%files -n ghc-%{pkg_name}-prof -f ghc-%{pkg_name}-prof.files
%changelog