File R-VicmapR.spec of Package R-VicmapR

# Automatically generated by CRAN2OBS
# 
# Spec file for package VicmapR 
# This file is auto-generated using information in the package source, 
# esp. Description and Summary. Improvements in that area should be 
# discussed with upstream. 
# 
# Copyright (c) 2024 SUSE LINUX GmbH, Nuernberg, Germany. 
# 
# All modifications and additions to the file contributed by third parties 
# remain the property of their copyright owners, unless otherwise agreed 
# upon. The license for this file, and modifications and additions to the 
# file, is the same license as for the pristine package itself (unless the 
# license for the pristine package is not an Open Source License, in which 
# case the license is the MIT License). An "Open Source License" is a 
# license that conforms to the Open Source Definition (Version 1.9) 
# published by the Open Source Initiative. 
#  
# Please submit bugfixes or comments via http://bugs.opensuse.org/ 
# 
 
%global packname  VicmapR 
%global rlibdir   %{_libdir}/R/library 
 
Name:           R-%{packname} 
Version:        0.2.3 
Release:        0 
Summary:        Access Victorian Spatial Data Through Web File Services (WFS) 
Group:          Development/Libraries/Other 
License:        Apache License (== 2.0) 
URL:            http://cran.r-project.org/web/packages/%{packname} 
Source:         VicmapR_0.2.3.tar.gz 
Requires:       R-base 
Requires:	R-magrittr
Requires:	R-httr
Requires:	R-sf
Requires:	R-dplyr
Requires:	R-purrr
Requires:	R-cli
Requires:	R-DBI
Requires:	R-xml2
Requires:	R-glue
Requires:	R-dbplyr
Requires:	R-rlang
Requires:	R-curl
Requires:	R-rvest
Requires:	R-lubridate
Requires:	R-knitr
Requires:	R-kableExtra
Requires:	R-mapview
Requires:	R-leaflet
Requires:	R-stringr
Requires:	R-blob
Requires:	R-lifecycle
Requires:	R-pillar
Requires:	R-R6
Requires:	R-tibble
Requires:	R-tidyr
Requires:	R-tidyselect
Requires:	R-vctrs
Requires:	R-withr
Requires:	R-generics
Requires:	R-jsonlite
Requires:	R-mime
Requires:	R-openssl
Requires:	R-rmarkdown
Requires:	R-scales
Requires:	R-viridisLite
Requires:	R-htmltools
Requires:	R-rstudioapi
Requires:	R-digest
Requires:	R-svglite
Requires:	R-evaluate
Requires:	R-highr
Requires:	R-xfun
Requires:	R-yaml
Requires:	R-crosstalk
Requires:	R-htmlwidgets
Requires:	R-jquerylib
Requires:	R-leaflet.providers
Requires:	R-png
Requires:	R-raster
Requires:	R-RColorBrewer
Requires:	R-sp
Requires:	R-timechange
Requires:	R-base64enc
Requires:	R-leafem
Requires:	R-leafpop
Requires:	R-satellite
Requires:	R-servr
Requires:	R-selectr
Requires:	R-classInt
Requires:	R-Rcpp
Requires:	R-s2
Requires:	R-units
Requires:	R-stringi
Requires:	R-e1071
Requires:	R-lazyeval
Requires:	R-fastmap
Requires:	R-geojsonsf
Requires:	R-brew
Requires:	R-uuid
Requires:	R-askpass
Requires:	R-fansi
Requires:	R-utf8
Requires:	R-terra
Requires:	R-bslib
Requires:	R-fontawesome
Requires:	R-tinytex
Requires:	R-wk
Requires:	R-plyr
Requires:	R-farver
Requires:	R-labeling
Requires:	R-munsell
Requires:	R-httpuv
Requires:	R-systemfonts
Requires:	R-cpp11
Requires:	R-pkgconfig
Requires:	R-sys
Requires:	R-cachem
Requires:	R-memoise
Requires:	R-sass
Requires:	R-proxy
Requires:	R-geometries
Requires:	R-jsonify
Requires:	R-rapidjsonr
Requires:	R-sfheaders
Requires:	R-later
Requires:	R-promises
Requires:	R-colorspace
Requires:	R-fs
Requires:	R-rappdirs
Requires:	gdal
Requires:	proj
 
# %%if 0%%{?sle_version} > 120400 || 0%%{?is_opensuse} 
# # Three others commonly needed 
# BuildRequires:  tex(ae.sty) 
# BuildRequires:  tex(fancyvrb.sty) 
# BuildRequires:  tex(inconsolata.sty) 
# BuildRequires:  tex(natbib.sty) 
# %else 
# BuildRequires:  texlive 
# %endif 
# BuildRequires:  texinfo 
BuildRequires:  fdupes 
BuildRequires:  R-base 
BuildRequires: 	R-magrittr
BuildRequires: 	R-httr
BuildRequires: 	R-sf
BuildRequires: 	R-dplyr
BuildRequires: 	R-purrr
BuildRequires: 	R-cli
BuildRequires: 	R-DBI
BuildRequires: 	R-xml2
BuildRequires: 	R-glue
BuildRequires: 	R-dbplyr
BuildRequires: 	R-rlang
BuildRequires: 	R-curl
BuildRequires: 	R-rvest
BuildRequires: 	R-lubridate
BuildRequires: 	R-knitr
BuildRequires: 	R-kableExtra
BuildRequires: 	R-mapview
BuildRequires: 	R-leaflet
BuildRequires: 	R-stringr
BuildRequires: 	R-blob
BuildRequires: 	R-lifecycle
BuildRequires: 	R-pillar
BuildRequires: 	R-R6
BuildRequires: 	R-tibble
BuildRequires: 	R-tidyr
BuildRequires: 	R-tidyselect
BuildRequires: 	R-vctrs
BuildRequires: 	R-withr
BuildRequires: 	R-generics
BuildRequires: 	R-jsonlite
BuildRequires: 	R-mime
BuildRequires: 	R-openssl
BuildRequires: 	R-rmarkdown
BuildRequires: 	R-scales
BuildRequires: 	R-viridisLite
BuildRequires: 	R-htmltools
BuildRequires: 	R-rstudioapi
BuildRequires: 	R-digest
BuildRequires: 	R-svglite
BuildRequires: 	R-evaluate
BuildRequires: 	R-highr
BuildRequires: 	R-xfun
BuildRequires: 	R-yaml
BuildRequires: 	R-crosstalk
BuildRequires: 	R-htmlwidgets
BuildRequires: 	R-jquerylib
BuildRequires: 	R-leaflet.providers
BuildRequires: 	R-png
BuildRequires: 	R-raster
BuildRequires: 	R-RColorBrewer
BuildRequires: 	R-sp
BuildRequires: 	R-timechange
BuildRequires: 	R-base64enc
BuildRequires: 	R-leafem
BuildRequires: 	R-leafpop
BuildRequires: 	R-satellite
BuildRequires: 	R-servr
BuildRequires: 	R-selectr
BuildRequires: 	R-classInt
BuildRequires: 	R-Rcpp-devel
BuildRequires: 	R-s2
BuildRequires: 	R-units
BuildRequires: 	R-stringi
BuildRequires: 	R-e1071
BuildRequires: 	R-lazyeval
BuildRequires: 	R-fastmap
BuildRequires: 	R-geojsonsf
BuildRequires: 	R-brew
BuildRequires: 	R-uuid
BuildRequires: 	R-askpass
BuildRequires: 	R-fansi
BuildRequires: 	R-utf8
BuildRequires: 	R-terra
BuildRequires: 	R-bslib
BuildRequires: 	R-fontawesome
BuildRequires: 	R-tinytex
BuildRequires: 	R-wk
BuildRequires: 	R-plyr
BuildRequires: 	R-farver
BuildRequires: 	R-labeling
BuildRequires: 	R-munsell
BuildRequires: 	R-httpuv
BuildRequires: 	R-systemfonts
BuildRequires: 	R-cpp11-devel
BuildRequires: 	R-pkgconfig
BuildRequires: 	R-sys
BuildRequires: 	R-cachem
BuildRequires: 	R-memoise
BuildRequires: 	R-sass
BuildRequires: 	R-proxy
BuildRequires: 	R-geometries-devel
BuildRequires: 	R-jsonify
BuildRequires: 	R-rapidjsonr-devel
BuildRequires: 	R-sfheaders-devel
BuildRequires: 	R-later
BuildRequires: 	R-promises
BuildRequires: 	R-colorspace
BuildRequires: 	R-fs
BuildRequires: 	R-rappdirs
BuildRequires: 	gdal
BuildRequires: 	gdal-devel
BuildRequires: 	geos-devel
BuildRequires: 	proj
BuildRequires: 	proj-devel
 
Suggests:	R-testthat
Suggests:	R-covr
Suggests:	R-rmarkdown
%description 
Easily interfaces R to spatial datasets available through the Victorian 
Government's WFS (Web Feature Service): 
<https://opendata.maps.vic.gov.au/geoserver/ows?request=GetCapabilities&service=wfs>, 
which allows users to read in 'sf' data from these sources. VicmapR 
uses the lazy querying approach and code developed by Teucher et al. 
(2021) for the 'bcdata' R package <doi:10.21105/joss.02927>. 
 
%prep 
%setup -q -c -n %{packname} 
# the next line is needed, because we build without --clean in between two packages 
rm -rf ~/.R  
 
 
%build 
 
%install 
mkdir -p %{buildroot}%{rlibdir} 
%{_bindir}/R CMD INSTALL -l %{buildroot}%{rlibdir} %{packname} 
test -d %{packname}/src && (cd %{packname}/src; rm -f *.o *.so) 
rm -f %{buildroot}%{rlibdir}/R.css 
%fdupes -s %{buildroot}%{rlibdir} 
 
#%%check 
#%%{_bindir}/R CMD check %%{packname} 
 
%files 
%dir %{rlibdir}/%{packname} 
%doc %{rlibdir}/%{packname}/DESCRIPTION
%{rlibdir}/%{packname}/INDEX
%{rlibdir}/%{packname}/Meta
%{rlibdir}/%{packname}/NAMESPACE
%doc %{rlibdir}/%{packname}/NEWS.md
%{rlibdir}/%{packname}/R
%{rlibdir}/%{packname}/data
%{rlibdir}/%{packname}/doc
%doc %{rlibdir}/%{packname}/help
%doc %{rlibdir}/%{packname}/html
%{rlibdir}/%{packname}/shapes
 
%changelog 
openSUSE Build Service is sponsored by