File erlang-chef_wm.spec of Package erlang-chef_wm
#
# spec file for package erlang-chef_wm
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: erlang-chef_wm
Version: 0.0.0+git.1359421197.e14a17f
%define mod_ver %(echo "%{version}" | cut -d "+" -f1)
Release: 0
License: Apache-2.0
Summary: The webmachine layer for erchef
Url: https://github.com/opscode/chef_wm
Group: Development/Libraries/Other
Source: chef_wm-%{version}.tar.gz
Patch01: PATCH01-remove-dependencies-rebar.config-file.patch
BuildRequires: erlang-rebar
BuildRequires: erlang-chef_authn
BuildRequires: erlang-chef_certgen
BuildRequires: erlang-chef_db
BuildRequires: erlang-chef_index
BuildRequires: erlang-chef_objects
BuildRequires: erlang-erlang-bcrypt
BuildRequires: erlang-webmachine
# The following is 'fast_log':
BuildRequires: erlang-fast-log-erlang
BuildRequires: erlang-mixer
BuildRequires: erlang-stats_hero
BuildRequires: erlang-folsom
Requires: erlang
Requires: erlang-rebar
Requires: erlang-chef_authn
Requires: erlang-chef_certgen
Requires: erlang-chef_db
Requires: erlang-chef_index
Requires: erlang-chef_objects
Requires: erlang-erlang-bcrypt
Requires: erlang-webmachine
Requires: erlang-fast-log-erlang
Requires: erlang-mixer
Requires: erlang-stats_hero
Requires: erlang-folsom
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
The "wm" stands for webmachine. This OTP application contains the core of the
erchef REST API implemented on top of the Webmachine toolkit. The URL routing
that matches URLs with Erlang modules handling requests for those URLs is
defined in `priv/dispatch.conf`. The README file in that repo has a more
detailed overview.
%prep
%setup -n chef_wm-%{version}
%patch01
%build
%rebar compile
%install
for dir in ebin include priv ; do
install -d %{buildroot}%{erlang_libdir}/chef_wm-%{mod_ver}/${dir}
cp -r ${dir}/* %{buildroot}%{erlang_libdir}/chef_wm-%{mod_ver}/${dir}/
done
%files
%defattr(-,root,root)
%dir %{erlang_libdir}/chef_wm-%{mod_ver}
%{erlang_libdir}/chef_wm-%{mod_ver}/ebin
%{erlang_libdir}/chef_wm-%{mod_ver}/priv
%{erlang_libdir}/chef_wm-%{mod_ver}/include
%changelog