File erlang-oauth2.spec of Package erlang-oauth2
#
# spec file for package erlang-oauth2
#
# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define app_name oauth2
Name: erlang-oauth2
Version: 0.6.0+git1443441946.e6da991
Release: 0
%define app_ver %(echo "%{version}" | cut -d "+" -f1)
License: MIT
Summary: Erlang Oauth2 server side implementation
Url: https://github.com/prefiks/oauth2
Group: Development/Libraries/Other
Source: %{app_name}-%{version}.tar.bz2
Requires: erlang
BuildRequires: erlang
BuildRequires: erlang-rebar
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
This library is designed to simplify the implementation of the server side of
OAuth2 (http://tools.ietf.org/html/rfc6749). It provides no support for
developing clients. See oauth2_client for support in accessing Oauth2 enabled
services.
%prep
%setup -q -n %{app_name}-%{version}
%build
%rebar compile
%install
for dir in ebin; do
mkdir -p %{buildroot}%{erlang_libdir}/%{app_name}-%{app_ver}/${dir}
cp -r ${dir}/* %{buildroot}%{erlang_libdir}/%{app_name}-%{app_ver}/${dir}/
done
%check
# missing dependencies
#rebar eunit
%files
%defattr(-,root,root)
%doc LICENSE README.md
%dir %{erlang_libdir}/%{app_name}-%{app_ver}
%dir %{erlang_libdir}/%{app_name}-%{app_ver}/ebin
%{erlang_libdir}/%{app_name}-%{app_ver}/ebin/%{app_name}.app
%{erlang_libdir}/%{app_name}-%{app_ver}/ebin/*.beam