File perl-App-BundleDeps.spec of Package perl-App-BundleDeps
#
# spec file for package perl-App-BundleDeps
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define cpan_name App-BundleDeps
Name: perl-App-BundleDeps
Version: 0.0.60
Release: 0
%define cpan_version 0.00006
License: Artistic-1.0 OR GPL-1.0-or-later
Summary: Bundle All Your Module Deps In A local::lib Dir
URL: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/D/DM/DMAKI/%{cpan_name}-%{cpan_version}.tar.gz
BuildArch: noarch
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(App::cpanminus) >= 0.9910
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.42
BuildRequires: perl(YAML)
BuildRequires: perl(local::lib)
Requires: perl(App::cpanminus) >= 0.9910
Requires: perl(YAML)
Requires: perl(local::lib)
Provides: perl(App::BundleDeps) = %{version}
Provides: perl(App::BundleDeps::Platypus)
%undefine __perllib_provides
Recommends: perl(YAML::XS)
%{perl_requires}
%description
App::BundleDeps is a tool that allows you to "bundle" all your
prerequisites in one local::lib installation. This is very useful when you
want to deploy your application.
%prep
%autosetup -n %{cpan_name}-%{cpan_version}
find . -type f ! -path "*/t/*" ! -name "*.pl" ! -path "*/bin/*" ! -path "*/script/*" ! -path "*/scripts/*" ! -name "configure" -print0 | xargs -0 chmod 644
%build
PERL_USE_UNSAFE_INC=1 perl Makefile.PL INSTALLDIRS=vendor
%make_build
%check
make test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%doc Changes
%changelog