File perl-Class-Delegation.spec of Package perl-Class-Delegation

#
# spec file for package perl-Class-Delegation
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define cpan_name Class-Delegation
Name:           perl-Class-Delegation
Version:        1.60.0
Release:        0
# 1.06 -> normalize -> 1.60.0
%define cpan_version 1.06
License:        Artistic-1.0 OR GPL-1.0-or-later
Summary:        Object-oriented delegation
URL:            https://metacpan.org/release/%{cpan_name}
Source0:        https://cpan.metacpan.org/authors/id/D/DC/DCONWAY/%{cpan_name}-%{cpan_version}.tar.gz
BuildArch:      noarch
BuildRequires:  perl
BuildRequires:  perl-macros
Provides:       perl(Class::Delegation) = %{version}
Provides:       perl(Class::Delegation::As::ARRAY)
Provides:       perl(Class::Delegation::As::CODE)
Provides:       perl(Class::Delegation::As::SCALAR)
Provides:       perl(Class::Delegation::As::Sent)
Provides:       perl(Class::Delegation::Send::ALL)
Provides:       perl(Class::Delegation::Send::ARRAY)
Provides:       perl(Class::Delegation::Send::CODE)
Provides:       perl(Class::Delegation::Send::OTHER)
Provides:       perl(Class::Delegation::Send::Regexp)
Provides:       perl(Class::Delegation::Send::SCALAR)
Provides:       perl(Class::Delegation::To::ALL)
Provides:       perl(Class::Delegation::To::ARRAY)
Provides:       perl(Class::Delegation::To::CODE)
Provides:       perl(Class::Delegation::To::Regexp)
Provides:       perl(Class::Delegation::To::SCALAR)
Provides:       perl(SELF)
%undefine       __perllib_provides
%{perl_requires}

%description
The Class::Delegation module simplifies the creation of delegation-based
class hierarchies, allowing a method to be redispatched:

  * to a single nominated attribute,

  * to a collection of nominated attributes in parallel, or

  * to any attribute that can handle the message.

  * the object itself

These three delegation mechanisms can be specified for:

  * a single method

  * a set of nominated methods collectively

  * any as-yet-undelegated methods

  * all methods, delegated or not.

%prep
%autosetup  -n %{cpan_name}-%{cpan_version}

find . -type f ! -path "*/t/*" ! -name "*.pl" ! -path "*/bin/*" ! -path "*/script/*" ! -path "*/scripts/*" ! -name "configure" -print0 | xargs -0 chmod 644

%build
perl Makefile.PL INSTALLDIRS=vendor
%make_build

%check
make test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%doc Changes README

%changelog
openSUSE Build Service is sponsored by