File perl-Crypt-OpenPGP.spec of Package perl-Crypt-OpenPGP

#
# spec file for package perl-Crypt-OpenPGP
#
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define cpan_name Crypt-OpenPGP
Name:           perl-Crypt-OpenPGP
Version:        1.12
Release:        0
Summary:        Pure-Perl OpenPGP implementation
License:        GPL-1.0-or-later OR Artistic-1.0
Group:          Development/Libraries/Perl
URL:            http://search.cpan.org/dist/Crypt-OpenPGP/
Source0:        http://www.cpan.org/authors/id/S/SR/SROMANOV/Crypt-OpenPGP-%{version}.tar.gz
BuildRequires:  iputils
BuildRequires:  openssl
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Alt::Crypt::RSA::BigInt)
BuildRequires:  perl(Bytes::Random::Secure)
BuildRequires:  perl(Compress::Zlib)
BuildRequires:  perl(Crypt::Blowfish)
BuildRequires:  perl(Crypt::CAST5_PP)
BuildRequires:  perl(Crypt::DES_EDE3)
BuildRequires:  perl(Crypt::DSA)
BuildRequires:  perl(Crypt::IDEA)
BuildRequires:  perl(Crypt::RIPEMD160)
BuildRequires:  perl(Crypt::Rijndael)
BuildRequires:  perl(Crypt::Twofish)
BuildRequires:  perl(Data::Buffer) >= 0.04
BuildRequires:  perl(Digest::MD5)
BuildRequires:  perl(Digest::SHA)
BuildRequires:  perl(ExtUtils::MakeMaker)
BuildRequires:  perl(File::HomeDir)
BuildRequires:  perl(LWP::UserAgent)
BuildRequires:  perl(MIME::Base64)
BuildRequires:  perl(Math::BigInt)
BuildRequires:  perl(Math::BigInt::GMP)
BuildRequires:  perl(Test::Exception)
BuildRequires:  perl(Test::More)
BuildRequires:  perl(URI::Escape)
Requires:       openssl
Requires:       perl(Alt::Crypt::RSA::BigInt)
Requires:       perl(Bytes::Random::Secure)
Requires:       perl(Compress::Zlib)
Requires:       perl(Crypt::Blowfish)
Requires:       perl(Crypt::CAST5_PP)
Requires:       perl(Crypt::DES_EDE3)
Requires:       perl(Crypt::DSA)
Requires:       perl(Crypt::IDEA)
Requires:       perl(Crypt::RIPEMD160)
Requires:       perl(Crypt::Rijndael)
Requires:       perl(Crypt::Twofish)
Requires:       perl(Data::Buffer) >= 0.04
Requires:       perl(Digest::MD5)
Requires:       perl(Digest::SHA)
Requires:       perl(File::HomeDir)
Requires:       perl(Filter::Util::Call)
Requires:       perl(LWP::UserAgent)
Requires:       perl(MIME::Base64)
Requires:       perl(Math::BigInt)
Requires:       perl(Math::BigInt::GMP)
Requires:       perl(URI::Escape)
BuildArch:      noarch
%{perl_requires}

%description
_Crypt::OpenPGP_ is a pure-Perl implementation of the OpenPGP standard[1].
In addition to support for the standard itself, _Crypt::OpenPGP_ claims
compatibility with many other PGP implementations, both those that support
the standard and those that preceded it.

_Crypt::OpenPGP_ provides signing/verification, encryption/decryption,
keyring management, and key-pair generation; in short it should provide you
with everything you need to PGP-enable yourself. Alternatively it can be
used as part of a larger system; for example, perhaps you have a
web-form-to-email generator written in Perl, and you'd like to encrypt
outgoing messages, because they contain sensitive information.
_Crypt::OpenPGP_ can be plugged into such a scenario, given your public
key, and told to encrypt all messages; they will then be readable only by
you.

This module currently supports 'RSA' and 'DSA' for digital signatures, and
'RSA' and 'ElGamal' for encryption/decryption. It supports the symmetric
ciphers '3DES', 'Blowfish', 'IDEA', 'Twofish', 'CAST5', and 'Rijndael'
('AES'). 'Rijndael' is supported for key sizes of '128', '192', and '256'
bits. _Crypt::OpenPGP_ supports the digest algorithms 'MD5', 'SHA-1', and
'RIPE-MD/160'. And it supports 'ZIP' and 'Zlib' compression.

%prep
%setup -q -n %{cpan_name}-%{version}
# t/13-keygen.t hangs in OBS and random entropy generating attemts fails
rm t/13-keygen.t

%build
export AUTOMATED_TESTING=1
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}

%check
export AUTOMATED_TESTING=1
make %{?_smp_mflags} test

%install
%perl_make_install
find %{buildroot}/%{_prefix} -name *.bs -a -size 0 | xargs rm -f
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes CREDITS README

%changelog
openSUSE Build Service is sponsored by