File perl-Daemon-Control.spec of Package perl-Daemon-Control

#
# spec file for package perl-Daemon-Control
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define cpan_name Daemon-Control
Name:           perl-Daemon-Control
Version:        0.1.10
Release:        0
%define cpan_version 0.001010
License:        Artistic-1.0 OR GPL-1.0-or-later
Summary:        Create init scripts in Perl
URL:            https://metacpan.org/release/%{cpan_name}
Source0:        https://cpan.metacpan.org/authors/id/S/SY/SYMKAT/%{cpan_name}-%{cpan_version}.tar.gz
Source1:        cpanspec.yml
BuildArch:      noarch
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.59
BuildRequires:  perl(File::Path) >= 2.08
BuildRequires:  perl(Test::More) >= 0.88
Requires:       perl(File::Path) >= 2.08
Provides:       perl(Daemon::Control) = %{version}
%undefine       __perllib_provides
%{perl_requires}

%description
Daemon::Control provides a library for creating init scripts in perl. Your
perl script just needs to set the accessors for what and how you want
something to run and the library takes care of the rest.

You can launch programs through the shell ('/usr/sbin/my_program') or
launch Perl code itself into a daemon mode. Single and double fork methods
are supported, and in double-fork mode all the things you would expect such
as reopening STDOUT/STDERR, switching UID/GID etc are supported.

%prep
%autosetup  -n %{cpan_name}-%{cpan_version}

%build
PERL_USE_UNSAFE_INC=1 perl Makefile.PL INSTALLDIRS=vendor
%make_build

%check
make test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%doc Changes

%changelog
openSUSE Build Service is sponsored by