File perl-JSON-PP.spec of Package perl-JSON-PP
#
# spec file for package perl-JSON-PP
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define cpan_name JSON-PP
Name: perl-JSON-PP
Version: 4.16
Release: 0
License: Artistic-1.0 OR GPL-1.0-or-later
Summary: JSON::XS compatible pure-Perl module
URL: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/I/IS/ISHIGAKI/%{cpan_name}-%{version}.tar.gz
Source1: cpanspec.yml
BuildArch: noarch
BuildRequires: perl
BuildRequires: perl-macros
%{perl_requires}
# MANUAL BEGIN
# zypper vcmp 2.27200 2.93
# 2.27200 is newer than 2.93
# => Provide a package version which is bigger....
Provides: %{name} = %{version}000-%{release}
Provides: perl(JSON::PP) = %{version}000
# MANUAL END
%description
JSON::PP is a pure perl JSON decoder/encoder, and (almost) compatible to
much faster JSON::XS written by Marc Lehmann in C. JSON::PP works as a
fallback module when you use JSON module without having installed JSON::XS.
Because of this fallback feature of JSON.pm, JSON::PP tries not to be more
JavaScript-friendly than JSON::XS (i.e. not to escape extra characters such
as U+2028 and U+2029, etc), in order for you not to lose such
JavaScript-friendliness silently when you use JSON.pm and install JSON::XS
for speed or by accident. If you need JavaScript-friendly RFC7159-compliant
pure perl module, try JSON::Tiny, which is derived from Mojolicious web
framework and is also smaller and faster than JSON::PP.
JSON::PP has been in the Perl core since Perl 5.14, mainly for CPAN
toolchain modules to parse META.json.
%prep
%autosetup -n %{cpan_name}-%{version}
%build
perl Makefile.PL INSTALLDIRS=vendor
%make_build
%check
make test
%install
%perl_make_install
%perl_process_packlist
# MANUAL BEGIN
%if 0%{?suse_version} >= 1210
# newer perl has these included
rm %{buildroot}/%{_mandir}/man1/json_pp.1
rm %{buildroot}/%{_bindir}/json_pp
%endif
# MANUAL END
%perl_gen_filelist
%files -f %{name}.files
%doc Changes README
%changelog