File perl-Net-Sieve.spec of Package perl-Net-Sieve

#
# spec file for package perl-Net-Sieve
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define cpan_name Net-Sieve
Name:           perl-Net-Sieve
Version:        0.120.0
Release:        0
# 0.12 -> normalize -> 0.120.0
%define cpan_version 0.12
License:        Artistic-1.0 OR GPL-1.0-or-later
Summary:        Implementation of managesieve protocol to manage sieve scripts
URL:            https://metacpan.org/release/%{cpan_name}
Source0:        https://cpan.metacpan.org/authors/id/Y/YV/YVESAGO/%{cpan_name}-%{cpan_version}.tar.gz
Source1:        cpanspec.yml
BuildArch:      noarch
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Authen::SASL) >= 2.11
BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.36
BuildRequires:  perl(IO::Socket::INET6)
BuildRequires:  perl(IO::Socket::SSL)
Requires:       perl(Authen::SASL) >= 2.11
Requires:       perl(IO::Socket::INET6)
Requires:       perl(IO::Socket::SSL)
Provides:       perl(Net::Sieve) = %{version}
%undefine       __perllib_provides
%{perl_requires}

%description
*Net::Sieve* is a package for clients for the "MANAGESIEVE" protocol, which
is an Internet Draft protocol for manipulation of "Sieve" scripts in a
repository. More simply, Net::Sieve lets you control your mail-filtering
rule files on a mail server.

*Net::Sieve* supports the use of "TLS" via the "STARTTLS" command.
*Net::Sieve* open the connexion to the sieve server, methods allow to list
all scripts, activate or deactivate scripts, read, delete or put scripts.

Most of code come from the great Phil Pennock *sieve-connect* command-line
tool http://people.spodhuis.org/phil.pennock/software/.

See Net::Sieve::Script to manipulate Sieve scripts content.

%prep
%autosetup  -n %{cpan_name}-%{cpan_version}

%build
PERL_USE_UNSAFE_INC=1 perl Makefile.PL INSTALLDIRS=vendor
%make_build

%check
make test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%doc Changes README Todo
%license LICENSE

%changelog
openSUSE Build Service is sponsored by