File perl-Role-Basic.spec of Package perl-Role-Basic
#
# spec file for package perl-Role-Basic
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define cpan_name Role-Basic
Name: perl-Role-Basic
Version: 0.160.0
Release: 0
# 0.16 -> normalize -> 0.160.0
%define cpan_version 0.16
License: Artistic-1.0 OR GPL-1.0-or-later
Summary: Just roles. Nothing else
URL: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/O/OV/OVID/%{cpan_name}-%{cpan_version}.tar.gz
BuildArch: noarch
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(Module::Build) >= 0.42
Provides: perl(Role::Basic) = %{version}
%undefine __perllib_provides
%{perl_requires}
%description
For an extended discussion, see
http://blogs.perl.org/users/ovid/2010/12/rolebasic---when-you-only-want-rol
es.html.
Sometimes you want roles. You're not sure about Moose, Mouse, Moo and what
_was_ that damned Squirrel thing anyway? Then there's Class::Trait, but it
has a funky syntax and the maintainer's deprecated it in favor of
Moose::Role and you really don't care that it handles overloading, instance
application or has a workaround for the SUPER:: bug. You think a
meta-object protocol sounds nifty, but you don't understand it. Maybe
you're not sure you want the syntactic sugar for object declaration. Maybe
you've convinced your colleagues that roles are a good idea but they're
leery of dragging in Moose (your author has had this happen more than once
and heard of others making the same complaint). Sometimes you just want
good old-fashioned roles which let you separate class responsibility from
code reuse.
Whatever your reasons, this is the module you're looking for. It only
provides roles and its major design goals are safety and simplicity. It
also aims to be a _subset_ of Moose::Role behavior so that when/if you're
ready to upgrade, there will be minimal pain.
%prep
%autosetup -n %{cpan_name}-%{cpan_version} -p1
%build
perl Build.PL --installdirs=vendor
./Build build --flags=%{?_smp_mflags}
%check
./Build test
%install
./Build install --destdir=%{buildroot} --create_packlist=0
%perl_gen_filelist
%files -f %{name}.files
%doc Changes examples README
%changelog