File perl-XML-DT.spec of Package perl-XML-DT

#
# spec file for package perl-XML-DT
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define cpan_name XML-DT
Name:           perl-XML-DT
Version:        0.690.0
Release:        0
# 0.69 -> normalize -> 0.690.0
%define cpan_version 0.69
License:        Artistic-1.0 OR GPL-1.0-or-later
Summary:        Package for down translation of XML files
URL:            https://metacpan.org/release/%{cpan_name}
Source0:        https://cpan.metacpan.org/authors/id/A/AM/AMBS/%{cpan_name}-%{cpan_version}.tar.gz
Source1:        cpanspec.yml
BuildArch:      noarch
BuildRequires:  perl
BuildRequires:  perl-macros
#BuildRequires:  perl(HTTP::Simple)
BuildRequires:  perl(parent)
BuildRequires:  perl(XML::DTDParser) >= 2.0.0
BuildRequires:  perl(XML::LibXML) >= 1.54
#Requires:       perl(HTTP::Simple)
Requires:       perl(parent)
Requires:       perl(XML::DTDParser) >= 2.0.0
Requires:       perl(XML::LibXML) >= 1.54
Provides:       perl(XML::DT) = %{version}
%undefine       __perllib_provides
%{perl_requires}
# MANUAL BEGIN
BuildRequires:  perl(HTTP::Tiny)
Requires:       perl(HTTP::Tiny)
# MANUAL END

%description
This module processes XML files with an approach similar to OMNIMARK. As
XML parser it uses XML::LibXML module in an independent way.

You can parse HTML files as if they were XML files. For this, you must
supply an extra option to the hash:

 %hander = ( -html => 1,
             ...
           );

You can also ask the parser to recover from XML errors:

 %hander = ( -recover => 1,
             ...
           );

%prep
%autosetup  -n %{cpan_name}-%{cpan_version}

find . -type f ! -path "*/t/*" ! -name "*.pl" ! -path "*/bin/*" ! -path "*/script/*" ! -path "*/scripts/*" ! -name "configure" -print0 | xargs -0 chmod 644

%build
perl Makefile.PL INSTALLDIRS=vendor
%make_build

%check
make test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%doc Changes examples mkdtdskel mkdtskel mkxmltype README

%changelog
openSUSE Build Service is sponsored by