File perl-CPAN-Index-API.spec of Package perl-CPAN-Index-API
#
# spec file for package perl-CPAN-Index-API
#
# Copyright (c) 2019 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: perl-CPAN-Index-API
Version: 0.008
Release: 0
%define cpan_name CPAN-Index-API
Summary: Read and write CPAN index files
License: Artistic-1.0 OR GPL-1.0-or-later
Group: Development/Libraries/Perl
Url: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/C/CA/CAPOEIRAB/%{cpan_name}-%{version}.tar.gz
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(Class::Load)
BuildRequires: perl(Compress::Zlib)
BuildRequires: perl(LWP::Simple)
BuildRequires: perl(Moose)
BuildRequires: perl(Moose::Role)
BuildRequires: perl(Moose::Util::TypeConstraints)
BuildRequires: perl(MooseX::ClassAttribute)
BuildRequires: perl(Path::Class)
BuildRequires: perl(Path::Tiny)
BuildRequires: perl(Test::More) >= 0.88
BuildRequires: perl(Test::Most)
BuildRequires: perl(Test::XML)
BuildRequires: perl(Text::Template)
BuildRequires: perl(URI)
BuildRequires: perl(URI::file)
BuildRequires: perl(XML::Twig)
BuildRequires: perl(namespace::autoclean)
Requires: perl(Class::Load)
Requires: perl(Compress::Zlib)
Requires: perl(LWP::Simple)
Requires: perl(Moose)
Requires: perl(Moose::Role)
Requires: perl(Moose::Util::TypeConstraints)
Requires: perl(MooseX::ClassAttribute)
Requires: perl(Path::Class)
Requires: perl(Path::Tiny)
Requires: perl(Text::Template)
Requires: perl(URI)
Requires: perl(URI::file)
Requires: perl(XML::Twig)
Requires: perl(namespace::autoclean)
%{perl_requires}
%description
'CPAN::Index::API' is a library to read and write CPAN index files. See the
modules in the 'CPAN::Index::API::File' namespace for documentation on the
individual files supported.
This class provides a convenient interface for working with multiple files
from the same location at the same time.
%prep
%setup -q -n %{cpan_name}-%{version}
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%check
make test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes README
%license LICENSE
%changelog