File perl-Convert-Transcribe.spec of Package perl-Convert-Transcribe
#
# spec file for package perl-Convert-Transcribe
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: perl-Convert-Transcribe
Version: 0.02
Release: 0
%define cpan_name Convert-Transcribe
Summary: Perl extension for transcribing natural languages
License: GPL-1.0+ or Artistic-1.0
Group: Development/Libraries/Perl
Url: http://search.cpan.org/dist/Convert-Transcribe/
Source0: http://www.cpan.org/authors/id/T/TW/TWID/%{cpan_name}-%{version}.tar.gz
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: perl
BuildRequires: perl-macros
%{perl_requires}
%description
Transcriptions are transformations of a text from one alphabet into another
in a way which feels natural to humans.
This module allows you to specify transcriptions in a notation which
hopefully feels more natural than using Perl regexps.
Transcription files look as follows:
# a comment
a b > a # 'a' -> 'b' if followed by 'a'
a c > ! b # 'a' -> 'c' if not followed by 'b'
a d < b # 'a' -> 'd' if text transcribed ends in 'b'
a e < ! b # 'a' -> 'e' if text transcribed doesn't end in 'b'
a f < $ > $ # 'a' -> 'f' if followed by a word boundary and the
# text transcribed ends in a word boundary
a g # 'a' -> 'g' otherwise
Transcription files can be loaded from text strings or from files.
The module converts your transcription file into some Perl code which is
then eval'ed when you call transcribe(). You may inspect the code generated
by calling generated_code().
%prep
%setup -q -n %{cpan_name}-%{version}
%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}
%check
%{__make} test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes README
%changelog