File perl-Linux-DVB.spec of Package perl-Linux-DVB
#
# spec file for package perl-Linux-DVB
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: perl-Linux-DVB
Version: 1.03
Release: 0
%define cpan_name Linux-DVB
Summary: Interface to (Some Parts of) the Linux Dvb Api
License: CHECK(GPL-1.0+ or Artistic-1.0)
Group: Development/Libraries/Perl
Url: http://search.cpan.org/dist/Linux-DVB/
Source0: http://www.cpan.org/authors/id/M/ML/MLEHMANN/%{cpan_name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(Canary::Stability) >= 2001
%{perl_requires}
%description
This module provides an interface to the Linux DVB API. It is a
straightforward translation of the C API. You should read the Linux DVB API
description to make any sense of this module. It can be found here:
http://www.linuxtv.org/docs/dvbapi/dvbapi.html
All constants from _frontend.h_ and _demux.h_ are exported by their C name
and by default.
Noteworthy differences to the C API: unions and sub-structs are usually
translated into flat perl hashes, i.e 'struct.u.qam.symbol_rate' becomes
'$struct->{symbol_rate}'.
Noteworthy limitations of this module include: No interface to the video,
audio and net devices. If you need this functionality bug the author.
%prep
%setup -q -n %{cpan_name}-%{version}
find . -type f -print0 | xargs -0 chmod 644
%build
%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
%{__make} %{?_smp_mflags}
%check
%{__make} test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes COPYING README
%changelog