File perl-perfSONAR_PS-Services-MA-Status.spec of Package perl-perfSONAR_PS-Services-MA-Status

#
# spec file for package perl-perfSONAR_PS-Services-MA-Status
#
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           perl-perfSONAR_PS-Services-MA-Status
Version:        0.09
Release:        0
%define cpan_name perfSONAR_PS-Services-MA-Status
Summary:        Module That Provides Methods for A
License:        You should have received a copy of the Internet2 Intellectual Property Framework along with this software. If not, see <http://www.internet2.edu/membership/ip.html>
Group:          Development/Libraries/Perl
Url:            http://search.cpan.org/dist/perfSONAR_PS-Services-MA-Status/
Source0:        http://www.cpan.org/authors/id/P/PE/PERFSONAR/%{cpan_name}-%{version}.tar.gz
BuildArch:      noarch
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(DBI)
BuildRequires:  perl(Log::Log4perl) >= 1
BuildRequires:  perl(Params::Validate) >= 0.64
BuildRequires:  perl(perfSONAR_PS::Client::LS::Remote) >= 0.09
BuildRequires:  perl(perfSONAR_PS::Client::Status::SQL) >= 0.09
BuildRequires:  perl(perfSONAR_PS::Common) >= 0.09
BuildRequires:  perl(perfSONAR_PS::Messages) >= 0.09
BuildRequires:  perl(perfSONAR_PS::Services::Base) >= 0.09
BuildRequires:  perl(perfSONAR_PS::Time) >= 0.09
BuildRequires:  perl(perfSONAR_PS::Topology::ID) >= 0.09
Requires:       perl(DBI)
Requires:       perl(Log::Log4perl) >= 1
Requires:       perl(Params::Validate) >= 0.64
Requires:       perl(perfSONAR_PS::Client::LS::Remote) >= 0.09
Requires:       perl(perfSONAR_PS::Client::Status::SQL) >= 0.09
Requires:       perl(perfSONAR_PS::Common) >= 0.09
Requires:       perl(perfSONAR_PS::Messages) >= 0.09
Requires:       perl(perfSONAR_PS::Services::Base) >= 0.09
Requires:       perl(perfSONAR_PS::Time) >= 0.09
Requires:       perl(perfSONAR_PS::Topology::ID) >= 0.09
%{perl_requires}

%description
This module, in conjunction with other parts of the perfSONAR-PS framework,
handles specific messages from interested actors in search of link status
data.

There are two major message types that this service can act upon: -
MetadataKeyRequest - Given some metadata about a specific measurement,
request a re-playable 'key' to faster access underlying data. -
SetupDataRequest - Given either metadata or a key regarding a specific
measurement, retrieve data values. - MeasurementArchiveStoreRequest - Given
some metadata or a key and some link status information, updates status
information about a given link. =cut

use base 'perfSONAR_PS::Services::Base';

use fields 'LS_CLIENT', 'CLIENT', 'LOGGER', 'MDOUTPUT', 'LINKSBYID',
'NODESBYNAME', 'ENABLE_COMPAT';

use strict; use warnings; use Log::Log4perl qw(get_logger); use
Params::Validate qw(:all); use Data::Dumper;

use perfSONAR_PS::Time; use perfSONAR_PS::Common; use
perfSONAR_PS::Messages; use perfSONAR_PS::Client::LS::Remote; use
perfSONAR_PS::Client::Status::SQL; use perfSONAR_PS::Topology::ID; use
perfSONAR_PS::ParameterValidation;

our $VERSION = 0.09;

my %status_namespaces = ( nmwg => "http://ggf.org/ns/nmwg/base/2.0/",
select=>"http://ggf.org/ns/nmwg/ops/select/2.0/",
nmtopo=>"http://ogf.org/schema/network/topology/base/20070828/",
topoid=>"http://ogf.org/schema/network/topology/id/20070828/",
ifevt=>"http://ggf.org/ns/nmwg/event/status/base/2.0/",
nmtl2=>"http://ggf.org/ns/nmwg/topology/l2/3.0/", );

%prep
%setup -q -n %{cpan_name}-%{version}
find . -type f -print0 | xargs -0 chmod 644

%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
%{__make} %{?_smp_mflags}

%check
%{__make} test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%defattr(-,root,root,755)
%doc Changes LICENSE psCreateStatusDB README

%changelog
openSUSE Build Service is sponsored by