File python-pysmi.spec of Package python-pysmi

#
# spec file for package python-pysmi
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%if 0%{?suse_version} > 1500
%bcond_without libalternatives
%else
%bcond_with libalternatives
%endif

%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name:           python-pysmi
Version:        0.3.4
Release:        0
Summary:        SNMP SMI/MIB Parser
License:        BSD-2-Clause
URL:            http://pysmi.sourceforge.net/
Source:         https://files.pythonhosted.org/packages/source/p/pysmi/pysmi-%{version}.tar.gz
BuildRequires:  %{python_module ply}
BuildRequires:  fdupes
BuildRequires:  python-rpm-macros
Requires:       python-ply
%if %{with libalternatives}
Requires:       alts
%else
Requires(post): update-alternatives
Requires(postun): update-alternatives
%endif
BuildArch:      noarch
%python_subpackages

%description
A pure-Python implementation of SNMP/SMI MIB parsing and conversion library.
Can produce PySNMP MIB modules.

Documentation: http://pysmi.sf.net

%prep
%setup -q -n pysmi-%{version}

%build
%python_build

%install
%python_install
mv %{buildroot}%{_bindir}/mibdump.py %{buildroot}%{_bindir}/mibdump
mv %{buildroot}%{_bindir}/mibcopy.py %{buildroot}%{_bindir}/mibcopy
%if ! %{with libalternatives}
  %python_clone -a %{buildroot}%{_bindir}/mibdump
  %python_clone -a %{buildroot}%{_bindir}/mibcopy
%else
  %python_clone %{buildroot}%{_bindir}/mibdump
  %python_clone %{buildroot}%{_bindir}/mibcopy  
  ln -sf %{_bindir}/alts %{buildroot}%{_bindir}/mibdump
  mkdir -p %{buildroot}%{_datadir}/libalternatives/mibdump
  %python_expand echo "binary=%{_bindir}/mibdump-%{$python_version}" > %{buildroot}%{_datadir}/libalternatives/mibdump/10%{$python_version_nodots}.conf
  ln -sf %{_bindir}/alts %{buildroot}%{_bindir}/mibcopy
  mkdir -p %{buildroot}%{_datadir}/libalternatives/mibcopy
  %python_expand echo "binary=%{_bindir}/mibcopy-%{$python_version}" > %{buildroot}%{_datadir}/libalternatives/mibcopy/10%{$python_version_nodots}.conf  
%endif
%python_expand %fdupes %{buildroot}%{$python_sitelib}

%if %{with libalternatives}
%pre
# removing old update-alternatives entries
if [ "$1" -gt 0 ] && [ -f %{_sbindir}/update-alternatives ] ; then
    %python_uninstall_alternative mibdump
    %python_uninstall_alternative mibcopy
fi    
%else
%post
%python_install_alternative mibdump
%python_install_alternative mibcopy

%postun
%python_uninstall_alternative mibdump
%python_uninstall_alternative mibcopy
%endif

#%%check
#nosetests # cannot be run without pysmnp which needs this package

%files %{python_files}
%license LICENSE.rst
%doc README.md CHANGES.rst
%{python_sitelib}/*
%if ! 0%{with libalternatives}
%python_alternative %{_bindir}/mibdump
%python_alternative %{_bindir}/mibcopy
%else
%dir %{_datadir}/libalternatives
%dir %{_datadir}/libalternatives/mibdump
%{_datadir}/libalternatives/mibdump/10%python_version_nodots.conf
%{_bindir}/mibdump
%{_bindir}/mibdump-%python_version
%dir %{_datadir}/libalternatives/mibcopy
%{_datadir}/libalternatives/mibcopy/10%python_version_nodots.conf
%{_bindir}/mibcopy
%{_bindir}/mibcopy-%python_version
%endif

%changelog
openSUSE Build Service is sponsored by