File cutemaze.spec of Package cutemaze
#
# spec file for package cutemaze
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%if 0%{?suse_version} >= 1550
%bcond_without qt6
%else
%bcond_with qt6
%endif
Name: cutemaze
Version: 1.3.0
Release: 0
Summary: Maze game
License: GPL-3.0-only
Group: Amusements/Games/Logic
URL: https://gottcode.org/cutemaze/
Source: https://gottcode.org/cutemaze/cutemaze-%{version}-src.tar.bz2
BuildRequires: gcc-c++
BuildRequires: hicolor-icon-theme
%if %{with qt6}
BuildRequires: cmake
BuildRequires: cmake(Qt6Core)
BuildRequires: cmake(Qt6LinguistTools)
BuildRequires: cmake(Qt6Gui)
BuildRequires: cmake(Qt6Svg)
BuildRequires: cmake(Qt6Widgets)
%else
BuildRequires: libqt5-qtbase-common-devel >= 5.9
BuildRequires: libqt5-qtsvg-devel >= 5.9
BuildRequires: libqt5-qttools-devel
%endif
BuildRequires: update-desktop-files
%description
CuteMaze is a simple, top-down game in which mazes are randomly generated using one of a choice
of several different algorithms.
You move the character through the maze while hunting for targets (cheese, by default)—the game
is won once all of these targets have been picked up.
%prep
%setup -q
%build
%if %{with qt6}
%cmake
%cmake_build
%else
export CXXFLAGS="%{optflags}"
%qmake5 PREFIX=%{_prefix}
%make_build
%endif
%install
%if %{with qt6}
%cmake_install
%else
make INSTALL_ROOT=%{buildroot} install
%endif
%suse_update_desktop_file %{name}
# Non standard path
rm -rfv %{buildroot}%{_datadir}/icons/hicolor/1024x1024
%find_lang %{name} --with-qt
%files -f %{name}.lang
%license COPYING
%doc ChangeLog README
%{_bindir}/%{name}
%dir %{_datadir}/%{name}
%dir %{_datadir}/%{name}/translations
%{_datadir}/applications/%{name}.desktop
%{_datadir}/metainfo/%{name}.appdata.xml
%{_mandir}/man6/%{name}.6%{?ext_man}
%{_datadir}/icons/hicolor/*/apps/%{name}.*
%changelog