File photoflow.spec of Package photoflow
#
# spec file for package PhotoFlow
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: photoflow
Version: 0.2.8
Release: 0
Summary: RAW image editor
License: GPL-3.0
Group: Productivity/Graphics/Viewers
Url: http://aferrero2707.github.io/PhotoFlow
Source: https://github.com/aferrero2707/PhotoFlow/archive/v%{version}.tar.gz#/PhotoFlow-%{version}.tar.gz
BuildRequires: cmake
BuildRequires: fftw3-threads-devel
BuildRequires: gcc-c++
BuildRequires: gettext-devel
BuildRequires: hicolor-icon-theme
BuildRequires: libjpeg-devel
BuildRequires: pkgconfig
BuildRequires: pugixml-devel
BuildRequires: update-desktop-files
BuildRequires: pkgconfig(OpenEXR)
BuildRequires: pkgconfig(exiv2)
BuildRequires: pkgconfig(fftw3) >= 3.0
BuildRequires: pkgconfig(gexiv2)
BuildRequires: pkgconfig(glib-2.0)
BuildRequires: pkgconfig(glibmm-2.4)
BuildRequires: pkgconfig(gmodule-2.0)
BuildRequires: pkgconfig(gobject-2.0)
BuildRequires: pkgconfig(gthread-2.0)
BuildRequires: pkgconfig(gtkmm-3.0)
BuildRequires: pkgconfig(lcms2)
BuildRequires: pkgconfig(lensfun)
BuildRequires: pkgconfig(libexif)
BuildRequires: pkgconfig(libpng)
BuildRequires: pkgconfig(libtiff-4)
BuildRequires: pkgconfig(libxml-2.0)
BuildRequires: pkgconfig(orc-0.4)
BuildRequires: pkgconfig(pango)
BuildRequires: pkgconfig(pangoft2)
BuildRequires: pkgconfig(pixman-1)
BuildRequires: pkgconfig(sigc++-2.0)
BuildRequires: pkgconfig(vips) >= 8.5.1
BuildRequires: pkgconfig(zlib)
BuildRequires: fdupes
Recommends: %{name}-lang
ExclusiveArch: %{ix86} x86_64
%description
A fully non-destructive photo retouching program providing a complete
layer-based workflow including RAW image development.
%lang_package
%prep
%setup -q -n PhotoFlow-%{version}
BUILDDATE=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%b %d %Y')
BUILDTIME=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%H:%M')
sed -e "s/__DATE__/\"$BUILDDATE\"/" \
-e "s/__TIME__/\"$BUILDTIME\"/" \
-i $(grep -rl '__DATE__\|__TIME__')
sed -i 's/^\_//;/^$/d' $(find -name \*.desktop)
%build
export CFLAGS="%{optflags} -fno-strict-aliasing"
%cmake \
-DINSTALL_PREFIX=%{_prefix} \
-DBUNDLED_LENSFUN=ON \
-DUSE_GTKMM3=ON \
-L
make %{?_smp_mflags}
%install
%cmake_install
find %{buildroot} -type f -name \*.*~ -delete -print
%suse_update_desktop_file %{name}
%fdupes -s %{buildroot}%{_datadir}
%find_lang %{name}
%post
%icon_theme_cache_post
%desktop_database_post
%postun
%icon_theme_cache_postun
%desktop_database_postun
%files
%defattr(-,root,root)
%doc CHANGELOG LICENSE README.md
%{_bindir}/%{name}
%{_datadir}/applications/%{name}.desktop
%{_datadir}/icons/hicolor/*/apps/%{name}.??g
%{_datadir}/%{name}/
%files lang -f %{name}.lang
%defattr(-,root,root)
%changelog