File kgraft-manual_en.spec of Package kgraft-manual_en

#
# spec file for package sle-ha-geo-manuals_en
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%bcond_without PDF
Name:           kgraft-manual_en
%define my_lang en
%define my_book SLES-kgraft
Version:        12
Release:        0
# Commented--we now use in IBS prjconf (outdated!):
# Substitute: xmlgraphics-fop agfa-fonts xep xep-license xmlgraphics-fop
# agfa-fonts is only needed when building with xep
# BuildRequires: agfa-fonts
# BuildRequires: xep xep-license
Provides:       locale(desktop-data-SLE:en)
#OBS
Source:         art.kgraft_en_src_set.tar.bz2
#SOURCES
Source901:      doc_pre_checkin.sh
Source903:      attributes
BuildRequires:  daps > 1.99999
BuildRequires:  fdupes
BuildRequires:  suse-xsl-stylesheets > 1.99999
BuildRequires:  update-desktop-files
Requires:       dejavu-fonts
Requires:       google-opensans-fonts
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildArch:      noarch
Summary:        kGraft Manual (English)
License:        GFDL-1.2
Group:          Documentation/SUSE
Url:            https://www.suse.com/documentation/sles/
%define _defaultdocdir %{_datadir}/doc/manual
%define _docdir %{_datadir}/doc/manual


%description
The kGraft Manual (English).

%package -n sles-kgraft_en-pdf
Summary:        kGraft Manual (English, PDF)
Group:          Documentation/SUSE
#Provides:    locale(desktop-data-openSUSE:en)
###PDFOBS


%description -n sles-kgraft_en-pdf
PDF of the kGraft Manual (English, PDF).

%prep
#%%setup -c -q
%setup -c -q -n %{name}-%{version}/SLES-kgraft
#PREP
%setup -c -q -T -D -n %{name}-%{version}
find -name '*.png' -o -name '*.svg' | xargs chmod 644 || :
#PDFPREP

%build
%define my_all_dir  %{_builddir}/%{name}-%{version}/SLES-kgraft
cd %{my_all_dir}
package_dir=$(daps -d DC-SLES-kgraft package-html --xsltparam="'--param build.for.web=0'" --pagefiles)
my_ll=$(echo %{my_lang} | tr [:upper:] [:lower:])
bookhtml=$(echo $package_dir/*_%{my_lang}-html.tar.bz2)
bookhtml=${bookhtml##*/}
tar xvf $package_dir/$bookhtml
bk=${bookhtml%%_%{my_lang}-html.tar.bz2}
echo $bk > %{name}.filelist
cp $package_dir/*.page %name.page

#MAKE_DOC
# export FOP=fop
export FOP_STACK="-Xss2048K"
build_pdf () {
%if %{with PDF}
  book=$(echo ${1} | tr [:upper:] [:lower:])
  if [ -x /usr/bin/xep ]; then
    export XEP_LICENSE=/etc/xep/license.xml
    export XEP_HOME=/usr/share/xep
    # see https://sourceforge.net/p/daps/tickets/107/
    export XEP_OPTIONS="-valid"
    formatter=xep
  fi
  if [ -z "$formatter" ]; then
    formatter=$(daps -d DC-${1} showvariable VARIABLE=FORMATTER)
  fi
  if [ $formatter = fop ]; then
    # 2014-01-14: according to sknorr,
    # XSLTPARAM='\\\"--param hyphenate.verbatim=0\\\"' is no longer needed
    pkg_pdf=$(daps -d DC-${1} package-pdf --formatter=$formatter)
  else
    pkg_pdf=$(daps -d DC-${1} package-pdf --formatter=$formatter)
  fi
  pdfname=$(find $pkg_pdf -name '*.pdf')
# 2014-01-14: not sure whether we still need -pdf.document
#  docname=$(find $pkg_pdf -name '*-pdf.document')
#  if [ -z "$docname" ]; then
#    docname=$(find $pkg_pdf -name '*.document')
#    mv $docname ${docname%\.document}-pdf.document
#    docname=${docname%\.document}-pdf.document
#  fi
#  pwd
#  sed -i "
## remove useless comments and search settings
#/^Categories=/d
#/^DocPath=/d
#/^Name *=/i\
#Categories=System;Core;Translation;Documentation\n\
#DocPath=file://%%{_defaultdocdir}/${1}_en-pdf/${pdfname##*/}
#" $docname
#  {
#    echo $pdfname
#    echo $docname
#  } > ${book}_en-pdf.filelist
  echo $pdfname > ${book}_en-pdf.filelist

%else
: say build --with PDF
%endif
}
all_pdf_docs="SLES-kgraft"
[ -n "$all_pdf_docs" ] && for b in $all_pdf_docs; do build_pdf $b; done

%install
cd %{my_all_dir}
mkdir -p %{buildroot}%{_defaultdocdir}
# product is name without language code
%define gnome_dir %{_datadir}/gnome/help/kgraft-manual
install -d %{buildroot}%{gnome_dir}
#
cp -a --dereference $(head -n 1 %{name}.filelist) \
  %{buildroot}/%{_defaultdocdir}/%{name}
gnome_help_dir=%{_datadir}/help/C/gnome-help
mkdir -p %{buildroot}$gnome_help_dir
cp %name.page %{buildroot}$gnome_help_dir/%name.page
{
  echo "%dir $gnome_help_dir"
  echo "$gnome_help_dir/%name.page"
} > %name.filelist
# Create the link to make the book visible in yelp; bnc#866668
if [ %{my_lang} = "en" ]; then
  pushd %{buildroot}%{_datadir}/help/C
  ln -s ../../doc/manual/%{name} %{my_book}
  popd
  echo "%{_datadir}/help/C/%{my_book}" >> %name.filelist
fi
%if %{with PDF}
for f in *-pdf.filelist; do
  # cat $f
  mkdir %{buildroot}/%{_defaultdocdir}/${f%\.filelist}
  # PDF first
  cp -a --dereference $(head -n 1 $f) \
    %{buildroot}/%{_defaultdocdir}/${f%\.filelist}
  # remove first line and append the new location
  sed -i 1d $f
  echo "%{_defaultdocdir}/${f%\.filelist}" >> $f
  #PDFHTML_LIST
done
%endif

%fdupes '%{buildroot}%{_docdir}'

%if %{with PDF}
#PDFINST

%endif

#PDFXXX

%files -n sles-kgraft_en-pdf -f %{my_book}/sles-kgraft_en-pdf.filelist
%defattr(-, root, root)

#PDFFILES

%files -f %{my_book}/%{name}.filelist
%defattr(-, root, root)
%dir %{_defaultdocdir}
%{_defaultdocdir}/%{name}
#GNOME
#KDE4

%changelog
openSUSE Build Service is sponsored by