File libcgroup.spec of Package libcgroup
#
# spec file for package libcgroup
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: libcgroup
%define lname libcgroup1
Version: 0.41.rc1
Release: 0
Summary: Control groups management tools
License: LGPL-2.1
Group: System/Management
Url: http://sourceforge.net/projects/libcg/
Source: http://sourceforge.net/projects/libcg/files/libcgroup/v0.41.rc/libcgroup-0.41.rc1.tar.bz2
Source3: sysconfig.cgred
Source99: baselibs.conf
Patch5: initd_cgconfig.patch
Patch6: initd_cgred.patch
Patch9: do-not-version-pam-module.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: bison
BuildRequires: flex
BuildRequires: gcc-c++
BuildRequires: libtool
BuildRequires: pam-devel
BuildRequires: pkg-config
Requires: insserv
Requires: pam
%description
Control groups, a new kernel feature in Linux 2.6.24 provides a file
system interface to manipulate and control the details on task grouping
including creation of new task groups (control groups), permission
handling and task assignment.
%package -n %lname
Summary: Control groups management library
Group: System/Libraries
%description -n %lname
Control groups, a new kernel feature in Linux 2.6.24 provides a file
system interface to manipulate and control the details on task grouping
including creation of new task groups (control groups), permission
handling and task assignment.
%package devel
Summary: Control groups management tools devel package
Group: Development/Libraries/C and C++
Requires: %lname = %version
%description devel
Control groups, a new kernel feature in Linux 2.6.24 provides a file
system interface to manipulate and control the details on task grouping
including creation of new task groups (control groups), permission
handling and task assignment.
%package tools
Summary: Control groups management tools
Group: System/Management
# Added for openSUSE 12.3 to aid the solver.
Provides: libcgroup1:/usr/bin/cgexec
%description tools
Control groups, a new kernel feature in Linux 2.6.24 provides a file
system interface to manipulate and control the details on task grouping
including creation of new task groups (control groups), permission
handling and task assignment.
%prep
%setup -n libcgroup-%{version}
%patch5 -p1
%patch6 -p1
%patch9 -p1
%build
# only for GIT builds
%if 0
aclocal
libtoolize -c
autoconf
autoheader
automake --foreign --add-missing --copy
%endif
# ==============
autoreconf -f -i
%configure --enable-pam-module-dir=/%{_lib}/security --enable-initscript-install
export V=1
make %{?_smp_mflags}
%install
%makeinstall INITSCRIPTDIR=%{buildroot}/%{_sysconfdir}/init.d/
find $RPM_BUILD_ROOT -type f -name '*.la' -exec rm -f {} ';'
rm -f $RPM_BUILD_ROOT/%{_lib}/security/*.so.*
mkdir -p %{buildroot}/%{_localstatedir}/adm/fillup-templates/
install -m 644 %{SOURCE3} %{buildroot}/%{_localstatedir}/adm/fillup-templates/sysconfig.cgred
ln -s %{_sysconfdir}/init.d/cgred %{buildroot}/%{_sbindir}/rccgred
ln -s %{_sysconfdir}/init.d/cgconfig %{buildroot}/%{_sbindir}/rccgconfig
# remove setuid
chmod u-s $RPM_BUILD_ROOT/%{_bindir}/cgexec
# move lib to rootfs
libcgso=$(basename $RPM_BUILD_ROOT/%{_libdir}/libcgroup.so.*.*.*)
mkdir -p $RPM_BUILD_ROOT/%{_lib}
mv -f $RPM_BUILD_ROOT/%{_libdir}/libcgroup.so.*.*.* $RPM_BUILD_ROOT/%{_lib}
rm -f $RPM_BUILD_ROOT/%{_libdir}/libcgroup.so.1
ln -sf $libcgso $RPM_BUILD_ROOT/%{_lib}/libcgroup.so.1
ln -sf ../../%{_lib}/$libcgso $RPM_BUILD_ROOT/%{_libdir}/libcgroup.so
%post -n %lname -p /sbin/ldconfig
%postun -n %lname -p /sbin/ldconfig
%preun tools
%stop_on_removal cgred cgconfig
%post tools
%{fillup_and_insserv -f cgconfig}
%{fillup_and_insserv -n cgred}
%postun tools
%restart_on_update cgconfig cgred
%insserv_cleanup
%files -n %lname
%defattr(-,root,root)
/%{_lib}/libcgroup.so.*
%files tools
%defattr(-,root,root)
%doc COPYING
%doc README
%doc README_daemon
%doc samples/cgconfig.conf
%doc samples/cgrules.conf
%{_sysconfdir}/init.d/cgconfig
%{_sysconfdir}/init.d/cgred
%{_bindir}/cg*
%{_bindir}/ls*
%{_sbindir}/cg*
%{_sbindir}/rccgred
%{_sbindir}/rccgconfig
/%{_lib}/security/pam_cgroup.so
%{_localstatedir}/adm/fillup-templates/sysconfig.cgred
%{_mandir}/man[^3]/*
%files devel
%defattr(-,root,root)
%{_libdir}/libcgroup.so
%{_includedir}/libcgroup.h
%dir %{_includedir}/libcgroup
%{_includedir}/libcgroup/*.h
%{_libdir}/pkgconfig/libcgroup.pc
%changelog