File python3-pip.spec of Package python3-pip

#
# spec file for package python3-pip
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           python3-pip
Version:        1.5
Release:        0
Url:            http://www.pip-installer.org
Summary:        Pip installs packages. Python packages. An easy_install replacement
License:        MIT
Group:          Development/Languages/Python
Source:         http://pypi.python.org/packages/source/p/pip/pip-%{version}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
BuildRequires:  python3
%if 0%{?suse_version} == 1220
BuildRequires:  python3-2to3
%endif
BuildRequires:  python3-devel
BuildRequires:  python3-setuptools

# prevent build cycle with python3 requirement
#!BuildIgnore:  python3-pip

# Test requirements (not on SLE12)
%if 0%{?suse_version} != 1315
BuildRequires:  python3-mock
BuildRequires:  python3-pytest
BuildRequires:  python3-scripttest >= 1.3
BuildRequires:  python3-virtualenv >= 1.1.0
%endif

Requires:       python3-setuptools
Requires(post): update-alternatives
Requires(postun): update-alternatives
BuildArch:      noarch

%description
Pip is a replacement for easy_install. It uses mostly the same techniques for
finding packages, so packages that were made easy_installable should be
pip-installable as well.

%prep
%setup -q -n pip-%{version}
sed -i "s|#!/usr/bin/env python||g" pip/__init__.py # Fix non-executable script
2to3 -wvn .

%build
python3 setup.py build

%install
python3 setup.py install --prefix=%{_prefix} --root=%{buildroot}
rm %{buildroot}%{_bindir}/pip
ln -s %{_bindir}/pip%{py3_ver} %{buildroot}%{_bindir}/pip

%check
%if 0%{?suse_version} != 1315
python3 setup.py test
%endif

%pre
# Since /usr/bin/pip became ghosted to be used with update-alternatives, we have to get rid
# of the old binary resulting from the non-update-alternativies-ified package:
[[ ! -L %{_bindir}/pip ]] && rm -f %{_bindir}/pip
exit 0

%post
update-alternatives --install %{_bindir}/pip pip %{_bindir}/pip%{py3_ver} 30

%preun
if [ $1 -eq 0 ] ; then
    update-alternatives --remove pip %{_bindir}/pip%{py3_ver}
fi

%files
%defattr(-,root,root,-)
%doc AUTHORS.txt CHANGES.txt LICENSE.txt README.rst
%ghost %{_bindir}/pip
%{_bindir}/pip3
%{_bindir}/pip%{py3_ver}
%{python3_sitelib}/pip-%{version}-py%{py3_ver}.egg-info
%{python3_sitelib}/pip
%if 0%{?suse_version} >= 1230
%ghost %{_sysconfdir}/alternatives/pip
%endif

%changelog
openSUSE Build Service is sponsored by