File sblim-sfcc.spec of Package sblim-sfcc
#
# spec file for package sblim-sfcc
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: sblim-sfcc
Version: 2.2.7
Release: 0
Url: http://sblim.wiki.sourceforge.net/
Summary: Small Footprint CIM Client Library
License: EPL-1.0
Group: System/Management
Source: %{name}-%{version}.tar.bz2
Source1: autoconfiscate.sh
# PATCH-FIX-OPENSUSE: don't release op when used as value, upstream #2730
Patch: 0001-Don-t-release-op-when-used-as-value.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: gcc-c++
BuildRequires: libtool
%if 0%{?suse_version}
%if 0%{?suse_version} < 1020
BuildRequires: curl-devel
%else
BuildRequires: libcurl-devel
%endif
%else
BuildRequires: curl-devel
%endif
%description
Small Footprint CIM Client Library (sfcc) Runtime Libraries
%package devel
Summary: Small Footprint CIM Client Library
Group: Development/Libraries/C and C++
Requires: %{name} = %{version}
Requires: glibc-devel
%description devel
Small Footprint CIM Client Library (sfcc) Header Files and Link
Libraries
%prep
%setup -q
%patch -p1
%build
# autoconfiscate
sh %{S:1}
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
%configure --disable-static --with-pic
# RHEL5 ships with old libtool (see http://www.yolinux.com/TUTORIALS/C++XmlBeansxx.html)
%if 0%{?rhel_version} >= 500 || 0%{?centos_version} >= 500
%if 0%{?rhel_version} < 600 || 0%{?centos_version} < 600
rm -f libtool; ln -s /usr/bin/libtool .
%endif
%endif
make %{?jobs:-j%jobs}
%install
make DESTDIR=$RPM_BUILD_ROOT install docdir=%{_docdir}/%{name}
rm -f %{buildroot}%{_libdir}/*.la
rm -f %{buildroot}%{_libdir}/*.a
%clean
rm -rf $RPM_BUILD_ROOT
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%doc AUTHORS COPYING ChangeLog NEWS README
%dir %{_docdir}/%{name}
%{_docdir}/%{name}/*
%doc %{_mandir}/man3/*
%{_libdir}/*.so.*
# dlopen'ed lib
%{_libdir}/libcimcClientXML.so
%files devel
%defattr(-,root,root)
%{_includedir}/*
%{_libdir}/libcimcclient.so
%{_libdir}/libcmpisfcc.so
%changelog