File falkon.spec of Package falkon
#
# spec file for package falkon
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
# Copyright (c) 2015 Mariusz Fik <fisiu@opensuse.org>
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: falkon
Version: @SERVICE@
Release: 0
Summary: Qt-based web browser
License: GPL-3.0-or-later
Group: Productivity/Networking/Web/Browsers
URL: https://www.falkon.org
Source: %{name}-%{version}.tar.xz
# Search engine favicons.
Source1: obs.png
Source2: opensusesoftware.png
# PATCH-FEATURE-OPENSUSE falkon-defaults.patch -- Falkon defaults.
Patch0: %{name}-defaults.patch
BuildRequires: extra-cmake-modules >= 5.27.0
BuildRequires: fdupes
BuildRequires: hicolor-icon-theme
BuildRequires: libQt5Gui-private-headers-devel
BuildRequires: libqt5-qttools-devel
BuildRequires: pkgconfig
BuildRequires: update-desktop-files
BuildRequires: cmake(KF5Archive)
BuildRequires: cmake(KF5CoreAddons) >= 5.54.0
BuildRequires: cmake(KF5Crash)
BuildRequires: cmake(KF5I18n)
BuildRequires: cmake(KF5KIO)
BuildRequires: cmake(KF5Purpose)
BuildRequires: cmake(KF5Wallet)
BuildRequires: cmake(Qt5Concurrent)
BuildRequires: cmake(Qt5Core) >= 5.9.0
BuildRequires: cmake(Qt5DBus)
BuildRequires: cmake(Qt5Gui)
BuildRequires: cmake(Qt5Network)
BuildRequires: cmake(Qt5Positioning)
BuildRequires: cmake(Qt5PrintSupport)
BuildRequires: cmake(Qt5Qml)
BuildRequires: cmake(Qt5Quick)
BuildRequires: cmake(Qt5QuickWidgets)
BuildRequires: cmake(Qt5Script)
BuildRequires: cmake(Qt5Sql)
BuildRequires: cmake(Qt5Test)
BuildRequires: cmake(Qt5WebChannel)
BuildRequires: cmake(Qt5WebEngineCore)
BuildRequires: cmake(Qt5WebEngineWidgets)
BuildRequires: cmake(Qt5Widgets)
BuildRequires: cmake(Qt5X11Extras)
BuildRequires: pkgconfig(hunspell)
BuildRequires: pkgconfig(openssl)
BuildRequires: pkgconfig(xcb-atom)
%description
Falkon is a web browser based on the Qt Framework.
%package kwallet
Summary: KWallet plugin for Falkon
Group: Productivity/Networking/Web/Browsers
Requires: %{name} = %{version}
Requires: kwalletd5
Supplements: packageand(%{name}:kwalletd5)
%description kwallet
Plugin for the Falkon browser that allows storing passwords in
KWallet.
%prep
%setup -q
%patch0 -p1
# openSUSE icons.
cp -f %{SOURCE1} %{SOURCE2} src/lib/data/icons/sites/
%build
export USE_WEBGL=true
%cmake_kf5 -d build
%make_jobs
%install
%kf5_makeinstall DESTDIR=%{buildroot} -C build
%suse_update_desktop_file org.kde.%{name}
%fdupes %{buildroot}%{_kf5_sharedir}/
%find_lang %{name} --all-name --with-qt
%post
%desktop_database_post
%icon_theme_cache_post
/sbin/ldconfig
%postun
%desktop_database_postun
%icon_theme_cache_postun
/sbin/ldconfig
%files -f %{name}.lang
%doc CHANGELOG COPYING README.md
%exclude %{_kf5_plugindir}/%{name}/KDEFrameworksIntegration.so
%{_kf5_appstreamdir}/org.kde.%{name}.appdata.xml
%{_kf5_bindir}/%{name}
%{_kf5_libdir}/libFalkonPrivate.so.*
%{_kf5_plugindir}/%{name}/
%{_kf5_sharedir}/applications/org.kde.%{name}.desktop
%{_kf5_sharedir}/bash-completion/
%{_kf5_sharedir}/%{name}/
%{_kf5_sharedir}/icons/hicolor/*/apps/%{name}.*
%files kwallet
%{_kf5_plugindir}/%{name}/KDEFrameworksIntegration.so
%changelog