File kdebindings3-java.spec of Package kdebindings3-java

#
# spec file for package kdebindings3-java
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           kdebindings3-java
%define is_base 0
%define is_java 1
%define is_js 0
%define _mandir /opt/kde3/share/man
BuildRequires:  gcc-java
BuildRequires:  java-devel
BuildRequires:  kdemultimedia3-devel
BuildRequires:  kdepim3
%if %suse_version > 1020
BuildRequires:  unzip
%endif
Summary:        Java Bindings for KDE
License:        LGPL-2.1+
Group:          Development/Libraries/Java
Version:        3.5.10
Release:        0
Url:            http://www.kde.org/
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
Source0:        kdebindings-%{version}.tar.bz2
Patch0:         3_5_BRANCH.diff
Patch2:         perl.diff
Patch4:         fix-return-value-kjsembed.diff
#Patch5:       FIXME.diff
Patch6:         64bit.diff
Patch7:         split-files.diff
Patch8:         kdebindings3-java.diff
Patch9:         kdebindings-3.5.1_ruby_non_site_dir.patch
Patch10:        admin-no-hpi.diff
Patch11:        ruby-constness.diff

%description
Needed libraries to write applications in Java for Qt and KDE.



Authors:
--------
    The KDE Team <kde@kde.org>

%if %{is_base}

%package perl

# usesubdirs smoke
Summary:        perl
Group:          Development/Libraries/Perl

%description perl

%package ruby

Summary:        ruby
Group:          Development/Languages/Ruby

%description ruby
ruby

%endif
%if %{is_js}

%package devel

Summary:        devel package
Group:          Development/Languages/Other
Requires:       %name = %version
Requires:       kdelibs3-devel

%description devel
devel package
%endif

%prep
%setup -q -n kdebindings-%{version}
%patch0
%patch2
%patch4
#%patch5
#%patch6
%patch7
%patch8
%patch9
%patch11
# eventually we have a patch in kdelibs adding that
if test -f /opt/kde3/include/kscrollview.h; then
   echo "kscrollview.h" >> smoke/kde/kde_header_list
fi
rm -rf qtobjc kdeobjc
%if %{is_js}
:
%else
rm -rf kjsembed
%endif
%if %{is_base}
:
%else
rm -rf smoke dcopperl
%endif
rm -rf dcoppython
. /etc/opt/kde3/common_options
update_admin --no-unsermake
%patch10
make -f admin/Makefile.common cvs

%build
. /etc/opt/kde3/common_options
%if %{is_java}
export PATH=/usr/lib/java/bin:$PATH
%endif
configopts=
%if %{is_java}
configopts="--with-java-dir=/usr/lib/java/"
%endif
%if %{is_base}
configopts="--disable-final"
%endif
./configure \
  $configkde $configopts
%if %{is_base}
make
%else
make %{?jobs:-j %jobs}
%endif

%install
. /etc/opt/kde3/common_options
make DESTDIR=$RPM_BUILD_ROOT $INSTALL_TARGET
%if %{is_base}
%perl_process_packlist
%endif
%if %{is_js}
%suse_update_desktop_file -u kjscmd  Development 
%suse_update_desktop_file -u embedjs Development 
%endif

%clean
rm -rf ${RPM_BUILD_ROOT}

%post
%run_ldconfig

%postun
%run_ldconfig
%if %{is_base}

%files
%defattr(-,root,root)
%doc COPYING README AUTHORS COPYING.LIB ChangeLog NEWS  
/opt/kde3/include/smoke.h
/opt/kde3/%_lib/libsmoke*

%files perl
%defattr(-,root,root)
%dir /usr/lib/perl5/vendor_perl/*/*/DCOP
%dir /usr/lib/perl5/vendor_perl/*/*/auto/DCOP
%{perl_vendorarch}/DCOP.pm
%{perl_vendorarch}/DCOP/Object.pm
%{perl_vendorarch}/auto/DCOP/.packlist
%{perl_vendorarch}/auto/DCOP/DCOP.bs
%{perl_vendorarch}/auto/DCOP/DCOP.so
/var/adm/perl-modules/kdebindings3
%{_mandir}/man3/DCOP.3pm.gz

%files ruby
%defattr(-,root,root)
/opt/kde3/bin/krubyinit
/opt/kde3/bin/qtrubyinit
/opt/kde3/bin/rbqtapi
/opt/kde3/bin/rbqtsh
/opt/kde3/bin/rbkdeapi
/opt/kde3/bin/rbkdesh
/opt/kde3/bin/rbuic
/opt/kde3/bin/rbkconfig_compiler
/usr/%_lib/ruby/*
%endif
%if %{is_java}

%files
%defattr(-,root,root)
/opt/kde3/bin/koala
/opt/kde3/bin/javalib
/opt/kde3/%_lib/java
/opt/kde3/%_lib/libqtjava*
/opt/kde3/%_lib/libkdejava.*
%doc  /opt/kde3/share/doc/HTML/en/javalib
%endif
%if %{is_js}

%files
%defattr(-,root,root)
%dir /opt/kde3/share/icons/hicolor/16x16
%dir /opt/kde3/share/icons/hicolor/16x16/apps
%dir /opt/kde3/share/icons/hicolor/32x32
%dir /opt/kde3/share/icons/hicolor/32x32/apps
/opt/kde3/bin/kjscmd
/opt/kde3/bin/embedjs
/opt/kde3/bin/jsaccess
/opt/kde3/%_lib/kde3/libqprocessplugin.*
/opt/kde3/%_lib/kde3/libfileitemplugin.*
/opt/kde3/%_lib/kde3/libjavascript.*
/opt/kde3/share/apps/kjsembed
/opt/kde3/share/appl*/*/embedjs.desktop
/opt/kde3/share/services/qprocess_plugin.desktop
%_mandir/man1/kjscmd.1.gz
/opt/kde3/%_lib/kde3/libjsconsoleplugin.*
/opt/kde3/share/applications/kde/kjscmd.desktop
/opt/kde3/share/apps/kate
/opt/kde3/%_lib/kde3/libcustomobjectplugin.*
/opt/kde3/%_lib/kde3/libcustomqobjectplugin.*
/opt/kde3/share/services/customobject_plugin.desktop
/opt/kde3/share/services/customqobject_plugin.desktop
/opt/kde3/share/services/imagefx_plugin.desktop
/opt/kde3/share/servicetypes/binding_type.desktop
/opt/kde3/%_lib/libkjsembed.so.*
/opt/kde3/%_lib/kde3/libimagefxplugin.*
/opt/kde3/share/apps/embedjs
/opt/kde3/share/icons/*/*/*/embedjs.*
/opt/kde3/share/services/javascript.desktop
/opt/kde3/share/services/kfileitem_plugin.desktop

%files devel
%defattr(-,root,root)
/opt/kde3/include/kjsembed
/opt/kde3/%_lib/libkjsembed.so
/opt/kde3/%_lib/libkjsembed.la
%endif

%changelog
openSUSE Build Service is sponsored by