File PKGBUILD of Package ungoogled-chromium22
# Maintainer: Ungoogled Software Contributors
# Maintainer: networkException <git@nwex.de>
# Based on extra/chromium, with ungoogled-chromium patches
# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=ungoogled-chromium
pkgver=116.0.5845.110
pkgrel=2
_launcher_ver=8
_gcc_patchset=116-patchset-2
# ungoogled chromium variables
_uc_usr=ungoogled-software
_uc_ver=116.0.5845.110-1
pkgdesc="A lightweight approach to removing Google web service dependency"
arch=('x86_64')
url="https://github.com/ungoogled-software/ungoogled-chromium"
license=('BSD')
depends=(gtk3 nss alsa-lib xdg-utils libxss libcups libgcrypt ttf-liberation systemd dbus libpulse pciutils libva libffi desktop-file-utils hicolor-icon-theme fontconfig woff2 brotli libjpeg icu dav1d flac snappy libxml2 ffmpeg libwebp minizip opus harfbuzz re2 jsoncpp libxslt libpng freetype2)
makedepends=(python gn ninja clang lld gperf nodejs pipewire qt5-base java-runtime-headless git jack2 jre-openjdk-headless curl mesa at-spi2-core)
optdepends=('pipewire: WebRTC desktop sharing under Wayland'
'kdialog: support for native dialogs in Plasma'
'qt5-base: enable Qt5 with --enable-features=AllowQt'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: support for storing passwords in KWallet on Plasma')
provides=('chromium')
conflicts=('chromium')
options=('!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
$pkgname-$_uc_ver.tar.gz::https://github.com/$_uc_usr/ungoogled-chromium/archive/$_uc_ver.tar.gz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-$_gcc_patchset/chromium-$_gcc_patchset.tar.xz
#https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
chromium-drirc-disable-10bpc-color-configs.conf
use-oauth2-client-switches-as-default.patch
ozone-add-va-api-support-to-wayland.patch
REVERT-disable-autoupgrading-debug-info.patch
random-build-fixes.patch
Disable-plugins-enumeration.patch
AudioBuffer-AnalyserNode-fp-mitigations.patch
Disable-UA-full-version.patch)
sha256sums=('SKIP'
'SKIP'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'SKIP'
'babda4f5c1179825797496898d77334ac067149cac03d797ab27ac69671a7feb'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711'
'af20fc58aef22dd0b1fb560a1fab68d0d27187ff18fad7eb1670feab9bc4a8d8'
'1b782b0f6d4f645e4e0daa8a4852d63f0c972aa0473319216ff04613a0592a69'
'SKIP'
'SKIP'
'SKIP'
'SKIP')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
declare -gA _system_libs=(
#[brotli]=brotli
[dav1d]=dav1d
[ffmpeg]=ffmpeg
[flac]=flac
[fontconfig]=fontconfig
[freetype]=freetype2
[harfbuzz-ng]=harfbuzz
[icu]=icu
[jsoncpp]=jsoncpp
#[libaom]=aom # https://aomedia.googlesource.com/aom/+/706ee36dcc82
#[libavif]=libavif # https://github.com/AOMediaCodec/libavif/commit/4d2776a3
[libdrm]=
[libjpeg]=libjpeg
[libpng]=libpng
#[libvpx]=libvpx
[libwebp]=libwebp
[libxml]=libxml2
[libxslt]=libxslt
[opus]=opus
[re2]=re2
[snappy]=snappy
[woff2]=woff2
[zlib]=minizip
)
_unwanted_bundled_libs=(
$(printf "%s\n" ${!_system_libs[@]} | sed 's/^libjpeg$/&_turbo/')
)
prepare() {
cd "$srcdir/chromium-$pkgver"
# Allow building against system libraries in official builds
sed -i 's/OFFICIAL_BUILD/GOOGLE_CHROME_BUILD/' \
tools/generate_shim_headers/generate_shim_headers.py
# https://crbug.com/893950
sed -i -e 's/\<xmlMalloc\>/malloc/' -e 's/\<xmlFree\>/free/' \
third_party/blink/renderer/core/xml/*.cc \
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
third_party/libxml/chromium/*.cc \
third_party/maldoca/src/maldoca/ole/oss_utils.h
# Use the --oauth2-client-id= and --oauth2-client-secret= switches for
# setting GOOGLE_DEFAULT_CLIENT_ID and GOOGLE_DEFAULT_CLIENT_SECRET at
# runtime -- this allows signing into Chromium without baked-in values
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
# Upstream fixes
patch -Np1 -i ../Disable-plugins-enumeration.patch
patch -Np1 -i ../AudioBuffer-AnalyserNode-fp-mitigations.patch
patch -Np1 -i ../Disable-UA-full-version.patch
# Revert addition of compiler flag that needs newer clang
patch -Rp1 -i ../REVERT-disable-autoupgrading-debug-info.patch
# Build fixes
patch -Np1 -i ../random-build-fixes.patch
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../patches/chromium-114-maldoca-include.patch
patch -Np1 -i ../patches/chromium-114-ruy-include.patch
#patch -Np1 -i ../patches/chromium-114-tflite-include.patch
patch -Np1 -i ../patches/chromium-114-vk_mem_alloc-include.patch
#patch -Np1 -i ../patches/chromium-115-skia-include.patch
#patch -Np1 -i ../patches/chromium-114-maldoca-include.patch
#patch -Np1 -i ../patches/chromium-115-verify_name_match-include.patch
patch -Np1 -i ../patches/chromium-116-object_paint_properties_sparse-include.patch
patch -Np1 -i ../patches/chromium-116-profile_view_utils-include.patch
# Link to system tools required by the build
mkdir -p third_party/node/linux/node-linux-x64/bin
ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/
ln -s /usr/bin/java third_party/jdk/current/bin/
# VAAPI wayland support (https://github.com/ungoogled-software/ungoogled-chromium-archlinux/issues/161)
#patch -Np1 -i ../ozone-add-va-api-support-to-wayland.patch
# Ungoogled Chromium changes
_ungoogled_repo="$srcdir/$pkgname-$_uc_ver"
_utils="${_ungoogled_repo}/utils"
msg2 'Pruning binaries'
python "$_utils/prune_binaries.py" ./ "$_ungoogled_repo/pruning.list"
msg2 'Applying patches'
python "$_utils/patches.py" apply ./ "$_ungoogled_repo/patches"
msg2 'Applying domain substitution'
python "$_utils/domain_substitution.py" apply -r "$_ungoogled_repo/domain_regex.list" \
-f "$_ungoogled_repo/domain_substitution.list" -c domainsubcache.tar.gz ./
# Remove bundled libraries for which we will use the system copies; this
# *should* do what the remove_bundled_libraries.py script does, with the
# added benefit of not having to list all the remaining libraries
local _lib
for _lib in ${_unwanted_bundled_libs[@]}; do
find "third_party/$_lib" -type f \
\! -path "third_party/$_lib/chromium/*" \
\! -path "third_party/$_lib/google/*" \
\! -path "third_party/harfbuzz-ng/utils/hb_scoped.h" \
\! -regex '.*\.\(gn\|gni\|isolate\)' \
-delete
done
./build/linux/unbundle/replace_gn_files.py \
--system-libraries "${!_system_libs[@]}"
}
build() {
make -C chromium-launcher-$_launcher_ver
cd "$srcdir/chromium-$pkgver"
if check_buildoption ccache y; then
# Avoid falling back to preprocessor mode when sources contain time macros
export CCACHE_SLOPPINESS=time_macros
fi
export CC=clang
export CXX=clang++
export AR=ar
export NM=nm
local _flags=(
'custom_toolchain="//build/toolchain/linux/unbundle:default"'
'host_toolchain="//build/toolchain/linux/unbundle:default"'
'clang_base_path="/usr"'
'is_official_build=true' # implies is_cfi=true on x86_64
'symbol_level=0' # sufficient for backtraces on x86(_64)
#'chrome_pgo_phase=0' # needs newer clang to read the bundled PGO profile
'disable_fieldtrial_testing_config=true'
'blink_enable_generated_code_formatting=false'
'ffmpeg_branding="Chrome"'
'proprietary_codecs=true'
'rtc_use_pipewire=true'
'link_pulseaudio=true'
'use_custom_libcxx=false'
#'use_gnome_keyring=false'
'use_sysroot=false'
'use_system_libffi=true'
'use_custom_libcxx=false'
'enable_widevine=true'
'enable_rust=false'
'use_vaapi=true'
'enable_platform_hevc=true'
'enable_hevc_parser_and_hw_decoder=true'
)
if [[ -n ${_system_libs[icu]+set} ]]; then
_flags+=('icu_use_data_file=false')
fi
# Append ungoogled chromium flags to _flags array
_ungoogled_repo="$srcdir/$pkgname-$_uc_ver"
readarray -t -O ${#_flags[@]} _flags < "${_ungoogled_repo}/flags.gn"
# See https://github.com/ungoogled-software/ungoogled-chromium-archlinux/issues/123
CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt"
CXXFLAGS="$CFLAGS"
# Facilitate deterministic builds (taken from build/config/compiler/BUILD.gn)
CFLAGS+=' -Wno-builtin-macro-redefined'
CXXFLAGS+=' -Wno-builtin-macro-redefined'
CPPFLAGS+=' -D__DATE__= -D__TIME__= -D__TIMESTAMP__='
# Do not warn about unknown warning options
CFLAGS+=' -Wno-unknown-warning-option'
CXXFLAGS+=' -Wno-unknown-warning-option'
# Let Chromium set its own symbol level
CFLAGS=${CFLAGS/-g }
CXXFLAGS=${CXXFLAGS/-g }
# -fvar-tracking-assignments is not recognized by clang
CFLAGS=${CFLAGS/-fvar-tracking-assignments}
CXXFLAGS=${CXXFLAGS/-fvar-tracking-assignments}
# https://github.com/ungoogled-software/ungoogled-chromium-archlinux/issues/123
CFLAGS=${CFLAGS/-fexceptions}
CFLAGS=${CFLAGS/-fcf-protection}
CXXFLAGS=${CXXFLAGS/-fexceptions}
CXXFLAGS=${CXXFLAGS/-fcf-protection}
# This appears to cause random segfaults when combined with ThinLTO
# https://bugs.archlinux.org/task/73518
CFLAGS=${CFLAGS/-fstack-clash-protection}
CXXFLAGS=${CXXFLAGS/-fstack-clash-protection}
# https://crbug.com/957519#c122
CXXFLAGS=${CXXFLAGS/-Wp,-D_GLIBCXX_ASSERTIONS}
msg2 'Configuring Chromium'
gn gen out/Release --args="${_flags[*]}"
msg2 'Building Chromium'
ninja -C out/Release chrome chrome_sandbox chromedriver
}
package() {
cd chromium-launcher-$_launcher_ver
make PREFIX=/usr DESTDIR="$pkgdir" install
install -Dm644 LICENSE \
"$pkgdir/usr/share/licenses/chromium/LICENSE.launcher"
cd "$srcdir/chromium-$pkgver"
install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
install -D out/Release/chromedriver "$pkgdir/usr/bin/chromedriver"
install -Dm4755 out/Release/chrome_sandbox "$pkgdir/usr/lib/chromium/chrome-sandbox"
install -Dm644 ../chromium-drirc-disable-10bpc-color-configs.conf \
"$pkgdir/usr/share/drirc.d/10-$pkgname.conf"
install -Dm644 chrome/installer/linux/common/desktop.template \
"$pkgdir/usr/share/applications/chromium.desktop"
install -Dm644 chrome/app/resources/manpage.1.in \
"$pkgdir/usr/share/man/man1/chromium.1"
sed -i \
-e 's/@@MENUNAME@@/Chromium/g' \
-e 's/@@PACKAGE@@/chromium/g' \
-e 's/@@USR_BIN_SYMLINK_NAME@@/chromium/g' \
"$pkgdir/usr/share/applications/chromium.desktop" \
"$pkgdir/usr/share/man/man1/chromium.1"
install -Dm644 chrome/installer/linux/common/chromium-browser/chromium-browser.appdata.xml \
"$pkgdir/usr/share/metainfo/chromium.appdata.xml"
sed -ni \
-e 's/chromium-browser\.desktop/chromium.desktop/' \
-e '/<update_contact>/d' \
-e '/<p>/N;/<p>\n.*\(We invite\|Chromium supports Vorbis\)/,/<\/p>/d' \
-e '/^<?xml/,$p' \
"$pkgdir/usr/share/metainfo/chromium.appdata.xml"
local toplevel_files=(
chrome_100_percent.pak
chrome_200_percent.pak
chrome_crashpad_handler
libqt5_shim.so
resources.pak
v8_context_snapshot.bin
# ANGLE
libEGL.so
libGLESv2.so
# SwiftShader ICD
libvk_swiftshader.so
vk_swiftshader_icd.json
)
if [[ -z ${_system_libs[icu]+set} ]]; then
toplevel_files+=(icudtl.dat)
fi
cp "${toplevel_files[@]/#/out/Release/}" "$pkgdir/usr/lib/chromium/"
install -Dm644 -t "$pkgdir/usr/lib/chromium/locales" out/Release/locales/*.pak
for size in 24 48 64 128 256; do
install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \
"$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
done
for size in 16 32; do
install -Dm644 "chrome/app/theme/default_100_percent/chromium/product_logo_$size.png" \
"$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
done
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/chromium/LICENSE"
}
# vim:set ts=2 sw=2 et ft=sh: