File lutris.spec of Package lutris

#
# spec file for package lutris
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%global appid net.lutris.Lutris
%if 0%{?suse_version} > 1500
%define _py 3
%define _pyb 3
%else
%{?sle15_python_module_pythons}
%define _py 311
%define _pyb 3.11
%endif

Name:           lutris
Version:        0.5.17
Release:        0
Summary:        Manager for game installation and execution
License:        GPL-3.0-or-later
URL:            https://lutris.net
Source0:        https://lutris.net/releases/lutris_%{version}.tar.xz
BuildRequires:  fdupes
BuildRequires:  gettext-tools
BuildRequires:  meson
BuildRequires:  gobject-introspection
BuildRequires:  %{python_module devel >= 3.7}
BuildRequires:  %{python_module gobject}
BuildRequires:  %{python_module setuptools}
BuildRequires:  hicolor-icon-theme
BuildRequires:  pkgconfig
BuildRequires:  update-desktop-files

Requires:       cabextract
Requires:       curl
Requires:       fluid-soundfont-gm
Requires:       p7zip
Requires:       psmisc
Requires:       xrandr

Requires:       python%{_py}-Pillow
Requires:       python%{_py}-PyYAML
Requires:       python%{_py}-certifi
Requires:       python%{_py}-dbus-python
Requires:       python%{_py}-distro
Requires:       python%{_py}-protobuf
# controller support
Requires:       python%{_py}-evdev
Requires:       python%{_py}-gobject
Requires:       python%{_py}-gobject-Gdk
Requires:       python%{_py}-lxml
Requires:       python%{_py}-requests
%if %{with discord}
Requires:       python%{_py}-pypresence
%endif
%if %{with moddb}
Requires:       python%{_py}-moddb
%endif

# boo#1213440
Recommends:     ca-certificates-steamtricks
Recommends:     winetricks
BuildArch:      noarch
%lang_package

%description
Lutris allows to gather and manage (install, configure and launch)
all games acquired from any source, in a single interface.
This includes, for example, Steam or GOG games, Windows games (WINE),
or emulated console games and browser games.

%prep
%autosetup -n %{name}
sed -i "s|!%{_bindir}/env python3|!%{_bindir}/python%{_pyb}|" share/lutris/bin/lutris-wrapper

%build
%meson
%meson_build

%install
%meson_install
%find_lang %{name}
%python3_fix_shebang_path %{buildroot}%{_bindir}/*
%python3_fix_shebang_path %{buildroot}%{_datadir}/%{name}/bin/*
%fdupes %{buildroot}

%files
%doc README.rst CONTRIBUTING.md AUTHORS
%license LICENSE
%{_bindir}/%{name}
%{_mandir}/man?/%{name}.?%{?ext_man}
%{_datadir}/%{name}
%{_datadir}/applications/%{appid}.desktop
%{_iconsdir}/hicolor/scalable/apps/%{name}.svg
%{_iconsdir}/hicolor/??x??/apps/%{name}.png
%{_iconsdir}/hicolor/???x???/apps/%{name}.png
%{python_sitelib}/%{name}
%{_datadir}/metainfo/%{appid}.metainfo.xml

%files lang -f %{name}.lang

%changelog
openSUSE Build Service is sponsored by