File ruby-gtk2.spec of Package ruby-gtk2

#
# spec file for package ruby-gtk2
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


Name:           ruby-gtk2
Version:        3.0.8
Release:        0
License:        LGPL-2.1
Summary:        Ruby Bindings for GTK+-2
Url:            http://ruby-gnome2.sourceforge.jp/
Group:          Development/Languages/Ruby
Source0:        http://downloads.sourceforge.net/ruby-gnome2/%{name}-%{version}.tar.gz
BuildRequires:  fdupes
BuildRequires:  ruby-devel > 2.0
BuildRequires:  %{rubygem cairo}
BuildRequires:  %{rubygem pkg-config}
BuildRequires:  pkgconfig(gobject-introspection-1.0)
BuildRequires:  pkgconfig(gtk+-2.0)
Requires:       ruby-atk
Requires:       ruby-gdkpixbuf2
Requires:       ruby-glib2
Requires:       ruby-pango
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description -n ruby-gtk2
Ruby/GTK2 is a Ruby binding of GTK+-2.0.x.

%package devel
Summary:        GTK2 Bindings for Ruby - Development Files
Group:          Development/Languages/Ruby
Requires:       ruby-atk
Requires:       ruby-devel
Requires:       ruby-gdkpixbuf2
Requires:       ruby-glib2
Requires:       ruby-gtk2
Requires:       ruby-pango
Requires:       %{rubygem cairo}

%description devel
Ruby-GTK2 is a set of Ruby language bindings for the GTK+-2.0.x
development environment.

%package sample-scripts
Summary:        Sample Scripts for Ruby-GTK2 Project
Group:          Development/Languages/Ruby
Requires:       ruby-gdkpixbuf2
Requires:       ruby-glib2
Requires:       ruby-gtk2
Requires:       ruby-pango
Requires:       %{rubygem cairo}
BuildArch:      noarch

%description sample-scripts
This package contains sample scripts for Ruby-GTK2 project.

%package -n ruby-atk
Summary:        Ruby Bindings for ATK-1
Group:          Development/Languages/Ruby
Requires:       ruby-glib2

%description -n ruby-atk
Ruby/ATK is a Ruby binding of ATK-1.0.x or later.

%package -n ruby-gdkpixbuf2
Summary:        Ruby Bindings for GdkPixbuf-2
Group:          Development/Languages/Ruby
Requires:       ruby-gtk2
Requires:       %{rubygem cairo}

%description -n ruby-gdkpixbuf2
Ruby/GdkPixbuf2 is a Ruby binding of GdkPixbuf-2.x.

%package -n ruby-gio2
Summary:        Ruby Bindings for GIO-2
Group:          Development/Languages/Ruby
Requires:       ruby-glib2

%description -n ruby-gio2
Ruby/GIO2 is a Ruby binding of GIO-2.0.x.

%package -n ruby-glib2
Summary:        Ruby Bindings for Glib-2
Group:          Development/Languages/Ruby

%description -n ruby-glib2
Ruby/GLib2 is a Ruby binding of GLib-2.x.

%package -n ruby-gobject-introspection
Summary:        Ruby Bindings for GObject Introspect
Group:          Development/Languages/Ruby
Requires:       ruby-glib2

%description -n ruby-gobject-introspection
Ruby/GObjectIntrospection is a Ruby binding of GObject Introspect.

%package -n ruby-pango
Summary:        Ruby Bindings for Pango-1
Group:          Development/Languages/Ruby
Requires:       ruby-glib2
Requires:       %{rubygem cairo}

%description -n ruby-pango
Ruby/Pango is a Ruby binding of Pango-1.x.

%prep
%setup -q
ruby extconf.rb

%build
make %{?_smp_mflags}

%install
%make_install
for f in AUTHORS COPYING.LIB NEWS README.md ; do
install -Dm 0644 "${f}" \
    %{buildroot}%{_defaultdocdir}/%{name}-sample-scripts/"${f}"
done
mkdir %{buildroot}%{_defaultdocdir}/%{name}-sample-scripts/examples
cp -R gdk_pixbuf2/sample \
    %{buildroot}%{_defaultdocdir}/%{name}-sample-scripts/examples/gdk_pixbuf2
cp -R glib2/sample \
    %{buildroot}%{_defaultdocdir}/%{name}-sample-scripts/examples/glib2
cp -R gtk2/sample \
    %{buildroot}%{_defaultdocdir}/%{name}-sample-scripts/examples/gtk2
cp -R pango/sample \
    %{buildroot}%{_defaultdocdir}/%{name}-sample-scripts/examples/pango
%fdupes -s %{buildroot}%{_defaultdocdir}/%{name}-sample-scripts/examples

%files
%defattr(-,root,root,-)
%doc gtk2/{README,COPYING.LIB}
%{_libdir}/ruby/site_ruby/%{rb_ver}/%{rb_arch}/gtk2.so
%{_libdir}/ruby/site_ruby/%{rb_ver}/gtk2/
%{_libdir}/ruby/site_ruby/%{rb_ver}/gtk2.rb

%files devel
%defattr(-,root,root,-)
%doc AUTHORS COPYING.LIB NEWS README.md
%{_libdir}/ruby/site_ruby/%{rb_ver}/%{rb_arch}/*.h

%files sample-scripts
%defattr(-,root,root,-)
%doc %{_defaultdocdir}/%{name}-sample-scripts/

%files -n ruby-atk
%defattr(-,root,root,-)
%doc atk/{README,COPYING.LIB}
%{_libdir}/ruby/site_ruby/%{rb_ver}/%{rb_arch}/atk.so
%{_libdir}/ruby/site_ruby/%{rb_ver}/atk.rb

%files -n ruby-gdkpixbuf2
%defattr(-,root,root,-)
%doc gdk_pixbuf2/{README,COPYING.LIB}
%{_libdir}/ruby/site_ruby/%{rb_ver}/%{rb_arch}/gdk_pixbuf2.so
%{_libdir}/ruby/site_ruby/%{rb_ver}/gdk_pixbuf2.rb

%files -n ruby-gio2
%defattr(-,root,root,-)
%doc gio2/{README.md,COPYING.LIB}
%{_libdir}/ruby/site_ruby/%{rb_ver}/%{rb_arch}/gio2.so
%{_libdir}/ruby/site_ruby/%{rb_ver}/gio2/
%{_libdir}/ruby/site_ruby/%{rb_ver}/gio2.rb

%files -n ruby-glib2
%defattr(-,root,root,-)
%doc glib2/{README.md,COPYING.LIB,TODO}
%{_libdir}/ruby/site_ruby/%{rb_ver}/%{rb_arch}/glib2.so
%{_libdir}/ruby/site_ruby/%{rb_ver}/glib2/
%{_libdir}/ruby/site_ruby/%{rb_ver}/glib2.rb
%{_libdir}/ruby/site_ruby/%{rb_ver}/glib-mkenums.rb
%{_libdir}/ruby/site_ruby/%{rb_ver}/gnome2/
%{_libdir}/ruby/site_ruby/%{rb_ver}/gnome2-raketask.rb
%{_libdir}/ruby/site_ruby/%{rb_ver}/mkmf-gnome2.rb

%files -n ruby-gobject-introspection
%defattr(-,root,root,-)
%doc gobject-introspection/{README.md,COPYING.LIB}
%{_libdir}/ruby/site_ruby/%{rb_ver}/%{rb_arch}/gobject_introspection.so
%{_libdir}/ruby/site_ruby/%{rb_ver}/gobject-introspection/
%{_libdir}/ruby/site_ruby/%{rb_ver}/gobject-introspection.rb

%files -n ruby-pango
%defattr(-,root,root,-)
%doc pango/{README,COPYING.LIB}
%{_libdir}/ruby/site_ruby/%{rb_ver}/%{rb_arch}/pango.so
%{_libdir}/ruby/site_ruby/%{rb_ver}/pango.rb

%changelog
openSUSE Build Service is sponsored by