File esbuild_version.patch of Package signal-desktop

Do not expect a specific esbuild version.

--- a/node_modules/esbuild/install.js
+++ b/node_modules/esbuild/install.js
@@ -101,7 +101,7 @@
     }
     throw err;
   }
-  if (stdout !== versionFromPackageJSON) {
+  if (0) {
     throw new Error(`Expected ${JSON.stringify(versionFromPackageJSON)} but got ${JSON.stringify(stdout)}`);
   }
 }

--- a/node_modules/esbuild/lib/main.js
+++ b/node_modules/esbuild/lib/main.js
@@ -743,7 +743,7 @@
     if (isFirstPacket) {
       isFirstPacket = false;
       let binaryVersion = String.fromCharCode(...bytes);
-      if (binaryVersion !== "0.17.11") {
+      if (0) {
         throw new Error(`Cannot start service: Host version "${"0.17.11"}" does not match binary version ${quote(binaryVersion)}`);
       }
       return;
--- a/sticker-creator/node_modules/esbuild/install.js
+++ b/sticker-creator/node_modules/esbuild/install.js
@@ -101,7 +101,7 @@
     }
     throw err;
   }
-  if (stdout !== versionFromPackageJSON) {
+  if (0) {
     throw new Error(`Expected ${JSON.stringify(versionFromPackageJSON)} but got ${JSON.stringify(stdout)}`);
   }
 }
--- a/sticker-creator/node_modules/esbuild/lib/main.js
+++ b/sticker-creator/node_modules/esbuild/lib/main.js
@@ -735,7 +735,7 @@
     if (isFirstPacket) {
       isFirstPacket = false;
       let binaryVersion = String.fromCharCode(...bytes);
-      if (binaryVersion !== "0.18.20") {
+      if (0) {
         throw new Error(`Cannot start service: Host version "${"0.18.20"}" does not match binary version ${quote(binaryVersion)}`);
       }
       return;
--- a/node_modules/@storybook/builder-manager/node_modules/esbuild/install.js
+++ b/node_modules/@storybook/builder-manager/node_modules/esbuild/install.js
@@ -101,7 +101,7 @@
     }
     throw err;
   }
-  if (stdout !== versionFromPackageJSON) {
+  if (0) {
     throw new Error(`Expected ${JSON.stringify(versionFromPackageJSON)} but got ${JSON.stringify(stdout)}`);
   }
 }
--- a/node_modules/@storybook/core-common/node_modules/esbuild/install.js
+++ b/node_modules/@storybook/core-common/node_modules/esbuild/install.js
@@ -101,7 +101,7 @@
     }
     throw err;
   }
-  if (stdout !== versionFromPackageJSON) {
+  if (0) {
     throw new Error(`Expected ${JSON.stringify(versionFromPackageJSON)} but got ${JSON.stringify(stdout)}`);
   }
 }
openSUSE Build Service is sponsored by