File trompeloeil.spec of Package trompeloeil
#
# spec file for package trompeloeil
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: trompeloeil
Version: 41
Release: 0
Summary: A thread-safe header-only mocking framework for C++
License: BSL-1.0
Group: Development/Languages/C and C++
URL: https://github.com/rollbear/trompeloeil
Source: https://github.com/rollbear/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
BuildRequires: cmake
BuildRequires: gcc-c++
BuildRequires: make
%description
A thread-safe header-only mocking framework for C++11/14.
%package devel
Summary: A thread-safe header-only mocking framework for C++
Group: Development/Languages/C and C++
%description devel
A thread-safe header-only mocking framework for C++11/14.
This package contains development files.
%prep
%autosetup -p1
%build
%cmake
%cmake_build
%install
%cmake_install
rm -rf %{buildroot}%{_datadir}/doc
%check
%ctest
%files devel
%license LICENSE_1_0.txt
%doc README.md ChangeLog docs
%dir %{_includedir}/boost
%{_includedir}/boost/trompeloeil.hpp
%dir %{_includedir}/catch2
%{_includedir}/catch2/trompeloeil.hpp
%dir %{_includedir}/criterion
%{_includedir}/criterion/trompeloeil.hpp
%dir %{_includedir}/crpcut
%{_includedir}/crpcut/trompeloeil.hpp
%dir %{_includedir}/cxxtest
%{_includedir}/cxxtest/trompeloeil.hpp
%dir %{_includedir}/doctest
%{_includedir}/doctest/trompeloeil.hpp
%dir %{_includedir}/gtest
%{_includedir}/gtest/trompeloeil.hpp
%{_includedir}/trompeloeil.hpp
%{_libdir}/cmake/%{name}
%changelog