File virtuoso.spec of Package virtuoso
#
# spec file for package virtuoso
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: virtuoso
Version: 6.1.6
Release: 67.1
Summary: Relational database server with RDF
License: GPL-2.0
Group: Productivity/Databases/Servers
Url: http://virtuoso.openlinksw.com/
Source0: %{name}-opensource-%{version}.tar.gz
# PATCH-FIX-OPENSUSE build-sanely.diff -- Build only things needed by KDE
Patch0: build-sanely.diff
# PATCH-FIX-OPENSUSE virtuoso-opensource-6.1.0-external_iodbc.patch asterios.dramis@gmail.com -- Build with external iodbc
Patch2: virtuoso-opensource-6.1.0-external_iodbc.patch
# PATCH-FIX-OPENSUSE Do not include build date and hostname in binaries
Patch6: virtuoso-no-build-dates.patch
BuildRequires: bison
BuildRequires: flex
BuildRequires: gperf
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%if !0%{?sles_version}
BuildRequires: htmldoc
%endif
BuildRequires: libiodbc-devel
BuildRequires: libopenssl-devel
%if 0%{?suse_version} <= 1140
BuildRequires: openssl
%endif
BuildRequires: libtool
BuildRequires: libwbxml2-devel
BuildRequires: openldap2-devel
# We can't use system pcre because internal pcre is modified for virtuoso's own use
#BuildRequires: pcre-devel
BuildRequires: zlib-devel
BuildRequires: pkgconfig(ImageMagick)
BuildRequires: pkgconfig(libxml-2.0)
Requires: virtuoso-drivers = %{version}
Requires: virtuoso-server = %{version}
%description
Virtuoso is an innovative Universal Server platform that delivers
an enterprise level Data Integration and Management solution for SQL,
RDF, XML, Web Services, and Business Processes. It includes an RDF
layer for semantic applications.
It is used by the Virtuoso backend for Soprano in KDE.
%package -n virtuoso-server
Summary: Virtuoso server
Group: Productivity/Databases/Servers
Requires: virtuoso-drivers = %{version}
%description -n virtuoso-server
Virtuoso is an innovative Universal Server platform that delivers
an enterprise level Data Integration and Management solution for SQL,
RDF, XML, Web Services, and Business Processes.
It is used by the Virtuoso backend for Soprano in KDE.
%package -n virtuoso-drivers
Summary: Virtuoso ODBC Driver
Group: Productivity/Databases/Servers
Provides: %{name} = %{version}
Obsoletes: %{name} < %{version}
%description -n virtuoso-drivers
Virtuoso is an innovative Universal Server platform that delivers
an enterprise level Data Integration and Management solution for SQL,
RDF, XML, Web Services, and Business Processes.
It is used by the Virtuoso backend for Soprano in KDE.
%prep
%setup -q -n %{name}-opensource-%{version}
%patch0 -p1
%patch2 -p1
%patch6 -p1
%build
# autogen.sh because of patching Makefile.am
./autogen.sh
%configure --without-internal-zlib \
--disable-static \
--with-layout=openSUSE \
--disable-all-vads \
--with-iodbc=%{_prefix}
make %{?_smp_mflags}
%install
%make_install
# Both binaries with and without libiodbc are built, keep the iodbc one
mv %{buildroot}%{_bindir}/virtuoso-iodbc-t %{buildroot}%{_bindir}/virtuoso-t
# Provide useful utilities
mkdir -p %{buildroot}%{_libdir}/virtuoso
rm %{buildroot}%{_bindir}/inifile
mv %{buildroot}%{_bindir}/isql %{buildroot}%{_bindir}/isql-vt
mv %{buildroot}%{_bindir}/isqlw %{buildroot}%{_bindir}/isqlw-vt
mv %{buildroot}%{_bindir}/isql-iodbc %{buildroot}%{_bindir}/isql-iodbc-vt
mv %{buildroot}%{_bindir}/isqlw-iodbc %{buildroot}%{_bindir}/isqlw-iodbc-vt
%files -n virtuoso-server
%defattr(-,root,root,-)
%doc %{_defaultdocdir}/virtuoso
%{_bindir}/virtuoso-t
%{_bindir}/isql*
%files -n virtuoso-drivers
%defattr(-,root,root,-)
%{_libdir}/virtodbc.la
%{_libdir}/virtodbc.so
%{_libdir}/virtodbc_r.la
%{_libdir}/virtodbc_r.so
%{_libdir}/virtodbcu.la
%{_libdir}/virtodbcu.so
%{_libdir}/virtodbcu_r.la
%{_libdir}/virtodbcu_r.so
%changelog
* Thu Aug 2 2012 toddrme2178@gmail.com
* Update to version 6.1.6
- Database engine
- Added support for SPARQL Service Description
- Added support for SOUNDEX and DIFFERENCE
- Added support for FROM SUBQUERY { ... } in quad map
- Added optimizations to JSON parser
- Added support for SSL Certificate Chains
- Added WebID protected endpoints templates
- Added error reporting if query compilation fails
- Added extra checks for db slices
- Added DSN names to explain() output
- Added support for CORS in Web Services
- Added propagation of LIMIT restrictions
- Added support for protocol switching, e.g., use of websockets
- Added generation of URL rewrite rules
- Fixed ETag calculation
- Fixed bad code for CLEAR GRAPH <xxxx>
- Fixed buffer overflow when using wide chars
- Fixed check to prevent out of range seek
- Fixed clear errors on ODBC connection handle
- Fixed compiler warnings
- Fixed datetime conversion
- Fixed external vars in table subqueries of scalar subqueries
- Fixed http_ses_arg is supposed to return ws_session
- Fixed issue with content type if already set by rewrite rule
- Fixed issue with transitive subqueries
- Fixed issue with "unknown BIF" message in SPARQL compiler error
- Fixed issue with Bison 2.6 code generation
- Fixed issue with SERVICE
- Fixed issue with UNIONs
- Fixed issue with incomplete RDF box
- Fixed memory leaks
- Fixed multi-column transitivity
- Fixed portability issues on FreeBSD, Solaris, and Mac OS X
- Fixed print of built-in expressions with multi-part alias name
- Fixed use provided password from ODBC connect handle
- Fixed valgrind warnings
- Updated documentation
- SPARQL and RDF
- Added auto-detection of RDFa and HTML+Microdata
- Added WebDAV REPORT method support for versioning
- Added WebDAV DET folder type
- Added Wolfram|Alpha cartridge
- Added debug code for sponger
- Added di: scheme
- Added extra debugging code to SPARQL engine
- Added new mime type application/n-triples
- Added procedure view for SPARQL BINDINGS
- Added rdb2rdf VAD for R2RML functionality
- Added support for INF, -INF, and NaN
- Added support for SPARQL 1.1 BINDINGS
- Added support for self-description
- Added support for hash-based proxy IRIs
- Added support for sponging of ftp URLs
- Added support for subqueries inside QUAP MAP { ... } groups
- Added support for tab-separated-values (TSV) output format in sparql
- Fixed LOAD SERVICE <SPARQL-Endpoint-URL> DATA for SPARQL-FED
- Fixed access rights and status for SPARUL_LOAD_SERVICE_DATA
- Fixed escaping of weird IRIs in RDF/XML output
- Fixed grants for SPARQL LOAD SERVICE lt;...> DATA
- Fixed issue joining two federated queries to the same host
- Fixed issue with double "AS" for lang in resultset
- Fixed issue with RDF View, bif:contains and option(?score)
- Fixed issue with SPARQL-FED code generation
- Fixed issue with graph level security check in SPARQL-FED subquery
- Fixed issue with transitive query
- Fixed issue with xsd:dateTime in SPARQL results
- Fixed issues loading microdata with namespace decls
- Fixed negation to use SPARQL 1.1 FILTER NOT EXISTS
- Fixed possible stack overflow on long UNIONs
- Fixed resource name encoding problem
- Fixed service SPARQL codegen with zero retvals
- Fixed support for SERVICE
- Improved error diagnostics for ALTER QUAD STORAGE <...> { DROP }
- Removed test for @rel, @rev, or @property from application/xhtml+xml
- Upgraded sesame driver to use Sesame 2.5.6
- Merged DBpedia VAD fixes
- Added registry setting dbp_last_modification to get SP returning last modified date
- Added support for If-Modified-Since
- Added support for rel="nofollow" on external links
- Fixed XHTML+RDFa validation
- Fixed check if modified
- Fixed reset timezone
- Fixed use owl graph for properties
- Merged iSPARQL vad
- Added control for raw URIs in SPARQL result set view
- Added persistence in permalinks
- Added alternate links in <head />
- Added support to remember RDF display/tab
- Added support to remember previous tab
- Upgraded MAP support for latest OpenLayers/OpenStreetmap
- Disabled dysfunctional NASA blue marble tiles
- ODS Applications
- Added initial API documentation + doxify templates
- Added advanced ACL settings for SPARQL or services authentication
- Added ACL filters
- Added support for mounting and WebID ACL protection of DropBox, Box.net/Box.com, Google Drive, and Microsoft SkyDrive folders
- Added support for private graphs
- Fixed redirect
- Merged ODS Addressbook fixes
- Added CalDAV Import
- Merged ODS Bookmark VAD
- Added Box (box.net, box.com) folder definition
- Added default values for cartridges
- Added support for WebDAV DET
- Added support for private graphs
- Fixed bad owner in some DET resources
- Fixed permission problem for some DETs
- Updated S3 DET folders with support for WebID ACLs
- Merged ODS Briefcase VAD
- Added ACL for IMAP DET folder
- Added mail notification for WebID sharing
- Fixed problem with editing mounted resources
- Fixed resource server side encryption problem
- Fixed sponger association with DETs feature
- Merged ODS Calendar VAD
- Added CalDAV and CardDAV DETs, and RESTful CRUD
- Fixed WebID write access
- Fixed daylight savings time on import to calendar
- Merged ODS Framework VAD
- Added Help links
- Added JSON output option for certgen
- Added link tags to user's pages
- Fixed 'Enable Automatic WebID Login' value
- Fixed private graphs init
- Fixed quotes on SPARQL vars
- Fixed remove session when ACL is altered
- Fixed REST interface page
- Fixed Semantic Pingback protocol
- Fixed void dset
- Updated CKeditor to version 3.6.3
* Mon Jul 30 2012 kruber@zib.de
- Update to 6.1.6 RC3
* Sat Apr 14 2012 dmueller@suse.com
- fix sequence point warning
* Tue Mar 20 2012 cgiboudeaux@gmx.com
- Update to 6.1.5
* Fixes over 6.1.4. See the Changelog file for full changelog.
* Drop suse-gawk-4.diff
* Mon Feb 20 2012 stefan.bruens@rwth-aachen.de
- create debuginfo for virtuoso server
* Wed Jan 25 2012 cgiboudeaux@gmx.com
- Update suse-gawk-4.diff. It can now be applied regardless of the
Opensuse version.
* Wed Jan 25 2012 idonmez@suse.com
- Back to internal PCRE, system one will result in runtime problems.
* Sat Jan 21 2012 crrodriguez@opensuse.org
- Use system PCRE.
- Do not include build dates in binaries.
* Tue Dec 27 2011 idonmez@suse.com
- Fix wrong size parameter in memset call
* Tue Nov 15 2011 coolo@suse.com
- add libtool as buildrequire to avoid implicit dependency
* Wed Nov 2 2011 cgiboudeaux@gmx.com
- Update to 6.1.4:
* Database Engine and SPARQL optimizations and enhancements.
* HTTP enhancements such as SPARQL 1.1 Graph Store and SPARQL CRUD
* New Sponger cartridges for Eventbrite, Eventful, Foursquare, Google+,
Google Place, Google Product, Google Profile, Gowalla, Guardian,
Hyperpublic, Jigsaw, LinkedIn, Plancast, ProgrammableWeb, Seatgeek, Seevl,
SimpleGeo, Upcoming, XRD, Zappos, and Zoopla.
* Fixes to existing cartridges. Fixes include deadlock handling, memory
handling and leaks, and SPARQL and SPARUL fixes.
* The Jena and Sesame2 drivers have been updated.
See NEWS file for more details.
Spec file updates:
* Removed fastjar from BuildRequires: (not needed).
- Removed: virtuoso-opensource-utf8.patch (fixed upstream).
- Use the internal libpcre to avoid runtime errors
- Added: suse-gawk-4.diff to avoid generating bugged code
(SR85083 reintroduced the gawk3 behaviour in gawk4, which makes the patched code fail)
* Tue Oct 25 2011 tittiatcoke@gmail.com
- Rename the isql* binaries instead of moving them to the virtuoso
directory. This would make it easier for users to find them.
* Tue Sep 27 2011 toddrme2178@gmail.com
- Removed INSTALL from documentation directory (fix for RPMLINT warning)
- Cleaned up spec file formatting
* Thu Sep 8 2011 idonmez@suse.com
- Add virtuoso-opensource-utf8.patch to fix UTF-8 related problems,
bko #271664
* Sun Aug 7 2011 toddrme2178@gmail.com
- Removed the virtuoso package. It only contained documentation
The documentation was moved to virtuoso-drivers.
virtuoso-server requires virtuoso-drivers so it will also get
the documentation.
* Fri Jul 8 2011 idonmez@novell.com
- Also package isql/isqlw binaries, useful for debugging Nepomuk
- Apply isql-buffer-overflow.patch to fix isql.c buffer overflow
* Mon Jun 27 2011 dmueller@suse.de
- add versioned requires
* Sun Jun 26 2011 asterios.dramis@gmail.com
- Update to 6.1.3:
* Lots of changes (see NEWS file)
- Spec file updates:
* Changes based on spec-cleaner run.
* openssl in BuildRequires is only needed for openSUSE <= 11.4.
* Added libiodbc-devel and openldap2-devel in BuildRequires.
* Added description for the patches based on openSUSE Patches Guidelines.
* Minor other updates.
- Removed libsrc/Wi/bif_file.c fix from rpmlint-fixes.diff patch (fixed
upstream).
- Added a patch (taken from Fedora) to fix build with external iodbc.
* Sun Apr 3 2011 crrodriguez@opensuse.org
- Use system zlib
- Use system pcre
- Do not include build date in binaries
- fix swapped memset arguments (memset-with-zero-length)
* Mon Dec 13 2010 toddrme2178@gmail.com
- Added optional build dependency
- ImageMagick
* Fri Jul 16 2010 dmueller@suse.de
- update to 6.1.2:
- Added FOAF+SSL based authentication for client connection
- Added support for following http redirects automatically
- Added extra functions for graph diff, iteration over dictionary
and obtaining biggest possible iri_id on given 32/64bit platform
- Added initial support for bif_python_exec
- Added semantic pingback client/server
- Fixed handling http, soap, xml-rpc using proxies and reverse-proxies
- Fixed when importing keys, let user decide which on to use as his
- Fixed handling of column default value of 0
- Fixed handling multiple certs
- Fixed support for bigint in parameter marshalling
- Fixed issue with default maxmempoolsize
- Fixed issue with extent map and free pages map
- Fixed memory leaks
- Fixed issue with freelist chain
- Fixed issue with partitioned top order by
- Added cartridges for CSV, Etsy, FaceBook OpenGraph, Html5, Idiomag,
Tumblr, Vimeo, Wine and YouTube
- Added more assertions to facets ontology
- Added label as ipf
- Added more properties for inferencing
- Added support for extra encodings
- Added initial support for ODATA atom serialization
- Added EAV and SPO labeling modes
- Added support for gz and zip compressed CSV
- Added CSV parser mode option
- Added CSV parser lax mode
- Added optimization for large descriptions on about page
- Fixed add escape to CR/LF in JSON format
- Fixed Odata, Tesco, html2 cartridges
- Fixed create list of unique graphs
- Fixed use label ontology to extract geo coordinates
- Fixed SPARQL handling of distinct
- Fixed SPARQL union selections
- Fixed SPARQL statement with implicit group by; do not remove
order by
- Fixed RDFa failing to parse both rel/rev
- Fixed abnormal long RDFa parsing of document with i18n uris
- Fixed issue with ?? with sparql compiler inside sql query
- Fixed support for subproperties of inverse functional properties
- Fixed support for loading aaa ruleset from multiple contology graphs
- Fixed gpf in sparul insert optimization
- Fixed issue with extra nulls in hash join or group by
- Enhanced iSPARQL using new internal RDF store for speed, browser
fixes and cosmetic changes
* Sun Apr 18 2010 tittiatcoke@gmail.com
- update to 6.1.1
* fixes for openSSL 1.0
* Fixed deadlock retry
* Fixed memory leaks
* For more details see : http://virtuoso.openlinksw.com/dataspace/dav/wiki/Main/VOSNews#Announcing Virtuoso Open-Source Edition v6.1.1
* Fri Mar 5 2010 coolo@novell.com
- remove authors
* Thu Mar 4 2010 coolo@novell.com
- readd comment autobuild erased
* Thu Feb 4 2010 tittiatcoke@gmail.com
- Update to 6.1.0
* official supported release for KDE 4.4 and higher
* Sat Oct 17 2009 wstephenson@novell.com
- Update to 5.0.12
* Fixed handling of single quote in iri (needed for nepomuk)
* Mon Oct 12 2009 tittiatcoke@gmail.com
- Update to svn snapshot 20091009.
+ Fullfilling requirement for new soprano-backend-virtuoso
* Thu May 7 2009 llunak@suse.cz
- Initial version