File rtl8814au.spec of Package rtl8814au
#
# spec file for package rtl8814au
#
#
# Copyright (c) 2025 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
# needssslcertforbuild
%define upstream_version 20250513
Name: rtl8814au
Summary: Realtek 8814au Wireless LAN Drivers
Version: %{upstream_version}
Release: 1.1
Group: System/Kernel
License: GPL-2.0
Url: https://github.com/morrownr/8814au
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Source0: %{name}.tar.gz
Patch1: ccflags.patch
Patch2: kernel515.patch
Patch3: kernel614.patch
Patch4: kernel615.patch
BuildRequires: %kernel_module_package_buildreqs
%if 0%{?sle_version} > 150600
BuildRequires: suse-module-tools-scriptlets
%endif
BuildRequires: pesign-obs-integration
BuildRequires: bc
Autoreqprov: on
%kernel_module_package -n rtl8814au -x debug -x trace -c %_sourcedir/_projectcert.crt -p %_sourcedir/preamble
%description
Notice: This notice is to let you know that a new mac80211 compatible
rtl8814au driver is available for testing. The plan is to upstream it to
the Linux Mainline kernel when testing shows the driver is stabile and
relatively bug free. We need your help to test and report.
The new driver rtw88 is available for testing at the following repo:
https://download.opensuse.org/repositories/home:/Sauerland:/hardware/
Remember to first remove the driver in this repo or from whatever repo
you may have installed.
My plan is to take this repo offline once the new driver is stabilized
in the Linux Mainline kernel as this driver has never been a very good
driver. It has just been the only thing we have had.
Regards,
@morrownr
Drivers for the rtl8814au chipset wireless adapters.
The module will be called "8814au.ko".
USB2.0/3.0 mode switch:
https://github.com/aircrack-ng/rtl8814au#usb2030-mode-switch
UEFI Secure Boot - (boot the kernel with signed):
https://github.com/aircrack-ng/rtl8814au#uefi-secure-boot---boot-the-kernel-with-signed
%prep
%setup -q -n %{name}
%patch -P 1 -p1
%patch -P 2 -p1
%patch -P 3 -p1
%patch -P 4 -p1
set -- *
mkdir source
mv "$@" source/
mkdir obj
%build
export EXTRA_CFLAGS='-DVERSION=\"%{version}\"'
export CONFIG_RTL8814AU=m
for flavor in %flavors_to_build; do
rm -rf obj/$flavor
cp -r source obj/$flavor
make -C /usr/src/linux-obj/%_target_cpu/$flavor modules \
M=$PWD/obj/$flavor
done
%install
#install the module
export INSTALL_MOD_PATH=$RPM_BUILD_ROOT
export INSTALL_MOD_DIR=updates
export CONFIG_RTL8814AU=m
export BRP_PESIGN_FILES='*.ko'
export BRP_PESIGN_COMPRESS_MODULE="xz"
for flavor in %flavors_to_build; do
make -C /usr/src/linux-obj/%_target_cpu/$flavor modules_install \
M=$PWD/obj/$flavor
done
%changelog