File perl-Class-Fields.spec of Package perl-Class-Fields
#
# spec file for package perl-Class-Fields
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define cpan_name Class-Fields
Name: perl-Class-Fields
Version: 0.204.0
Release: 0
# 0.204 -> normalize -> 0.204.0
%define cpan_version 0.204
License: Artistic-1.0 OR GPL-1.0-or-later
Summary: Inspect the fields of a class
URL: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/M/MS/MSCHWERN/%{cpan_name}-%{cpan_version}.tar.gz
Source1: cpanspec.yml
BuildArch: noarch
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(Carp::Assert)
Requires: perl(Carp::Assert)
Provides: perl(Class::Fields) = %{version}
Provides: perl(Class::Fields::Attribs) = 0.30.0
Provides: perl(Class::Fields::Fuxor) = 0.60.0
Provides: perl(Class::Fields::Inherit) = 0.60.0
Provides: perl(private) = 0.40.0
Provides: perl(protected) = 0.40.0
Provides: perl(public) = 0.40.0
%undefine __perllib_provides
%{perl_requires}
%description
*NOTE* This module, and the fields system, is largely obsolete. Please
consider using one of the many accessor generating modules, or just skip
directly to a complete object oriented system like Moose or Mouse.
A collection of utility functions/methods for examining the data members of
a class. It provides a nice, high-level interface that should stand the
test of time and Perl upgrades nicely.
%prep
%autosetup -n %{cpan_name}-%{cpan_version}
%build
perl Makefile.PL INSTALLDIRS=vendor
%make_build
%check
make test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%doc Changes
%changelog