File perl-Crypt-DH.spec of Package perl-Crypt-DH
#
# spec file for package perl-Crypt-DH
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define cpan_name Crypt-DH
Name: perl-Crypt-DH
Version: 0.70.0
Release: 0
# 0.07 -> normalize -> 0.70.0
%define cpan_version 0.07
License: Artistic-1.0 OR GPL-1.0-or-later
Summary: Diffie-Hellman key exchange system
URL: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/M/MI/MITHALDU/%{cpan_name}-%{cpan_version}.tar.gz
Source1: cpanspec.yml
BuildArch: noarch
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.59
BuildRequires: perl(Math::BigInt::GMP) >= 1.24
Requires: perl(Math::BigInt::GMP) >= 1.24
Provides: perl(Crypt::DH) = %{version}
%undefine __perllib_provides
%{perl_requires}
%description
_Crypt::DH_ is a Perl implementation of the Diffie-Hellman key exchange
system. Diffie-Hellman is an algorithm by which two parties can agree on a
shared secret key, known only to them. The secret is negotiated over an
insecure network without the two parties ever passing the actual shared
secret, or their private keys, between them.
%prep
%autosetup -n %{cpan_name}-%{cpan_version}
find . -type f ! -path "*/t/*" ! -name "*.pl" ! -path "*/bin/*" ! -path "*/script/*" ! -path "*/scripts/*" ! -name "configure" -print0 | xargs -0 chmod 644
# MANUAL BEGIN
sed -i -e 's/use inc::Module::Install/use lib q[.];\nuse inc::Module::Install/' Makefile.PL
# MANUAL END
%build
PERL_USE_UNSAFE_INC=1 perl Makefile.PL INSTALLDIRS=vendor
%make_build
%check
make test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%doc Changes README ToDo
%changelog