File perl-File-ChangeNotify.spec of Package perl-File-ChangeNotify
#
# spec file for package perl-File-ChangeNotify
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define cpan_name File-ChangeNotify
Name: perl-File-ChangeNotify
Version: 0.310.0
Release: 0
# 0.31 -> normalize -> 0.310.0
%define cpan_version 0.31
License: Artistic-2.0
Summary: Watch for changes to files, cross-platform style
URL: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/D/DR/DROLSKY/%{cpan_name}-%{cpan_version}.tar.gz
Source1: cpanspec.yml
BuildArch: noarch
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(Module::Pluggable::Object)
BuildRequires: perl(Module::Runtime)
BuildRequires: perl(Moo) >= 1.006
BuildRequires: perl(Moo::Role)
BuildRequires: perl(Test2::V0)
BuildRequires: perl(Test::More) >= 1.302015
BuildRequires: perl(Test::Requires)
BuildRequires: perl(Test::Without::Module)
BuildRequires: perl(Type::Utils)
BuildRequires: perl(Types::Standard)
BuildRequires: perl(namespace::autoclean)
Requires: perl(Module::Pluggable::Object)
Requires: perl(Module::Runtime)
Requires: perl(Moo) >= 1.006
Requires: perl(Moo::Role)
Requires: perl(Type::Utils)
Requires: perl(Types::Standard)
Requires: perl(namespace::autoclean)
Provides: perl(File::ChangeNotify) = %{version}
Provides: perl(File::ChangeNotify::Event) = %{version}
Provides: perl(File::ChangeNotify::Watcher) = %{version}
Provides: perl(File::ChangeNotify::Watcher::Default) = %{version}
Provides: perl(File::ChangeNotify::Watcher::Inotify) = %{version}
Provides: perl(File::ChangeNotify::Watcher::KQueue) = %{version}
%undefine __perllib_provides
%{perl_requires}
%description
This module provides an API for creating a File::ChangeNotify::Watcher
subclass that will work on your platform.
Most of the documentation for this distro is in
File::ChangeNotify::Watcher.
%prep
%autosetup -n %{cpan_name}-%{cpan_version}
%build
perl Makefile.PL INSTALLDIRS=vendor
%make_build
%check
make test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%doc Changes CODE_OF_CONDUCT.md CONTRIBUTING.md README.md
%license LICENSE
%changelog