File perl-MCE-Shared.spec of Package perl-MCE-Shared
#
# spec file for package perl-MCE-Shared
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define cpan_name MCE-Shared
Name: perl-MCE-Shared
Version: 1.893.0
Release: 0
# 1.893 -> normalize -> 1.893.0
%define cpan_version 1.893
License: Artistic-1.0 OR GPL-1.0-or-later
Summary: MCE extension for sharing data supporting threads and processes
URL: https://metacpan.org/release/%{cpan_name}
Source0: https://cpan.metacpan.org/authors/id/M/MA/MARIOROY/%{cpan_name}-%{cpan_version}.tar.gz
Source1: cpanspec.yml
BuildArch: noarch
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(MCE) >= 1.889
BuildRequires: perl(Test::More) >= 0.88
Requires: perl(MCE) >= 1.889
Provides: perl(MCE::Hobo) = %{version}
Provides: perl(MCE::Shared) = %{version}
Provides: perl(MCE::Shared::Array) = %{version}
Provides: perl(MCE::Shared::Base) = %{version}
Provides: perl(MCE::Shared::Cache) = %{version}
Provides: perl(MCE::Shared::Common) = %{version}
Provides: perl(MCE::Shared::Condvar) = %{version}
Provides: perl(MCE::Shared::Handle) = %{version}
Provides: perl(MCE::Shared::Hash) = %{version}
Provides: perl(MCE::Shared::Minidb) = %{version}
Provides: perl(MCE::Shared::Ordhash) = %{version}
Provides: perl(MCE::Shared::Queue) = %{version}
Provides: perl(MCE::Shared::Scalar) = %{version}
Provides: perl(MCE::Shared::Sequence) = %{version}
Provides: perl(MCE::Shared::Server) = %{version}
%undefine __perllib_provides
Recommends: perl(IO::FDPass) >= 1.200
Recommends: perl(Sereal::Decoder) >= 3.015
Recommends: perl(Sereal::Encoder) >= 3.015
%{perl_requires}
%description
This module provides data sharing capabilities for MCE supporting threads
and processes. MCE::Hobo provides threads-like parallelization for running
code asynchronously.
%prep
%autosetup -n %{cpan_name}-%{cpan_version}
%build
perl Makefile.PL INSTALLDIRS=vendor
%make_build
%check
make test
%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%doc Changes README.md
%license Copying LICENSE
%changelog