File perl-MooseX-MultiMethods.spec of Package perl-MooseX-MultiMethods

#
# spec file for package perl-MooseX-MultiMethods
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#


%define cpan_name MooseX-MultiMethods
Name:           perl-MooseX-MultiMethods
Version:        0.100.0
Release:        0
# 0.10 -> normalize -> 0.100.0
%define cpan_version 0.10
License:        Artistic-1.0 OR GPL-1.0-or-later
Summary:        Multi Method Dispatch based on Moose type constraints
URL:            https://metacpan.org/release/%{cpan_name}
Source0:        https://cpan.metacpan.org/authors/id/F/FL/FLORA/%{cpan_name}-%{cpan_version}.tar.gz
Source1:        cpanspec.yml
BuildArch:      noarch
BuildRequires:  perl
BuildRequires:  perl-macros
BuildRequires:  perl(Devel::Declare) >= 0.004000
BuildRequires:  perl(Devel::PartialDump)
BuildRequires:  perl(Moose)
BuildRequires:  perl(MooseX::Method::Signatures) >= 0.29
BuildRequires:  perl(MooseX::Types::Moose)
BuildRequires:  perl(MooseX::Types::VariantTable) >= 0.30.0
BuildRequires:  perl(Sub::Install)
BuildRequires:  perl(aliased)
BuildRequires:  perl(namespace::autoclean)
Requires:       perl(Devel::Declare) >= 0.004000
Requires:       perl(Devel::PartialDump)
Requires:       perl(Moose)
Requires:       perl(MooseX::Method::Signatures) >= 0.29
Requires:       perl(MooseX::Types::Moose)
Requires:       perl(MooseX::Types::VariantTable) >= 0.30.0
Requires:       perl(Sub::Install)
Requires:       perl(aliased)
Requires:       perl(namespace::autoclean)
Provides:       perl(MooseX::MultiMethods) = %{version}
Provides:       perl(MooseX::MultiMethods::Meta::Method) = %{version}
%undefine       __perllib_provides
%{perl_requires}
# MANUAL BEGIN
BuildRequires:  perl(Test::Exception)
BuildRequires:  perl(MooseX::Declare)
BuildRequires:  perl(Test::NoWarnings)
# MANUAL END

%description
This module provides multi method dispatch based on Moose type constraints.
It does so by providing a 'multi' keyword that extends the 'method' keyword
provided by MooseX::Method::Signatures.

When invoking a method declared as 'multi' a matching variant is being
searched in all the declared multi variants based on the passed parameters
and the declared type constraints. If a variant has been found, it will be
invoked. If no variant could be found, an exception will be thrown.

%prep
%autosetup  -n %{cpan_name}-%{cpan_version}

%build
perl Makefile.PL INSTALLDIRS=vendor
%make_build

%check
make test

%install
%perl_make_install
%perl_process_packlist
%perl_gen_filelist

%files -f %{name}.files
%doc Changes README
%license LICENSE

%changelog
openSUSE Build Service is sponsored by